This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 807124 - posix:us-west-1 region had some posix issues
posix:us-west-1 region had some posix issues
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: posix (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijay Bellur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 01:38 EDT by Saurabh
Modified: 2016-01-19 01:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 05:12:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2012-03-27 01:38:30 EDT
Description of problem:
/opt/qa/tools/posix-testsuite/tests/mkfifo/00.t  (Wstat: 0 Tests: 36 Failed: 3)
  Failed tests:  30-32
/opt/qa/tools/posix-testsuite/tests/rename/ren.t (Wstat: 0 Tests: 22 Failed: 1)
  Failed test:  4
/opt/qa/tools/posix-testsuite/tests/symlink/00.t (Wstat: 0 Tests: 14 Failed: 2)
  Failed tests:  11-12
/opt/qa/tools/posix-testsuite/tests/unlink/00.t  (Wstat: 0 Tests: 55 Failed: 8)
  Failed tests:  17, 35-36, 41-42, 47-48, 53


Version-Release number of selected component (if applicable):
3.3.0qa30

How reproducible:
all failures do not happen everytime

Steps to Reproduce:
1. create a distribute-replicate volume
2. nfs mount
3. start posix test
  
Actual results:
   some tests fail

Expected results:
   none of the test should have failed.

Additional info:
Comment 1 Saurabh 2012-03-27 04:59:40 EDT
We tried to investigate the issue further and found that most of the tests were during because of time comparisons. The failures might be happening as in all the four servers on which this distributed-replicated they are not having sync'ed timestamps and this presently seems to be more of aws issue, as even after starting the ntp service the timestamps were not similar.

Note You need to log in before you can comment on or make changes to this bug.