Bug 807142 - Space at the end of zone name should be trimmed
Space at the end of zone name should be trimmed
Status: CLOSED DUPLICATE of bug 864223
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Angus Thomas
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 03:24 EDT by Shveta
Modified: 2012-12-12 16:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-12 16:50:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
duplicate pool (177.73 KB, image/png)
2012-03-27 03:24 EDT, Shveta
no flags Details
new_zone (230.57 KB, image/png)
2012-03-27 04:32 EDT, Shveta
no flags Details

  None (edit)
Description Shveta 2012-03-27 03:24:42 EDT
Created attachment 572948 [details]
duplicate pool

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a pool new_zone
2. Create another pool new_zone 
Error displays
3.
  
Actual results:


Expected results:


Additional info:
rpm -qa|grep aeolus
aeolus-conductor-0.8.3-1.el6.noarch
aeolus-conductor-daemons-0.8.3-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.3-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-conductor-doc-0.8.3-1.el6.noarch


================================================

Rendered pools/new.html.haml within layouts/application (25.3ms)
undefined method `name' for nil:NilClass
/usr/share/aeolus-conductor/app/views/pools/_form.html.haml:14:in `_app_views_pools__form_html_haml___1731004519_70237638650660_942910'
 /usr/lib/ruby/gems/1.8/gems/haml-3.1.2/lib/haml/helpers/action_view_mods.rb:167:in `call'
 /usr/lib/ruby/gems/1.8/gems/haml-3.1.2/lib/haml/helpers/action_view_mods.rb:167:in `form_for_without_haml_xss'
 /usr/lib/ruby/gems/1.8/gems/haml-3.1.2/lib/haml/helpers.rb:255:in `with_tabs'
 /usr/lib/ruby/gems/1.8/gems/haml-3.1.2/lib/haml/helpers/action_view_mods.rb:167:in `form_for_without_haml_xss'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/helpers/capture_helper.rb:40:in `capture_without_haml'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/helpers/capture_helper.rb:172:in `with_output_buffer_without_haml_xss'
 /usr/lib/ruby/gems/1.8/gems/haml-3.1.2/lib/haml/helpers/xss_mods.rb:109:in `with_output_buffer'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/helpers/capture_helper.rb:40:in `capture_without_haml'
 /usr/lib/ruby/gems/1.8/gems/haml-3.1.2/lib/haml/helpers/action_view_mods.rb:92:in `capture'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/helpers/form_helper.rb:545:in `fields_for'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/helpers/form_helper.rb:320:in `form_for_without_haml'
 /usr/lib/ruby/gems/1.8/gems/haml-3.1.2/lib/haml/helpers/action_view_mods.rb:169:in `form_for_without_haml_xss'
 /usr/lib/ruby/gems/1.8/gems/haml-3.1.2/lib/haml/helpers/xss_mods.rb:132:in `form_for'
 /usr/share/aeolus-conductor/app/views/pools/_form.html.haml:1:in `_app_views_pools__form_html_haml___1731004519_70237638650660_942910'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/template.rb:135:in `send'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/template.rb:135:in `render'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/notifications.rb:54:in `instrument'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/template.rb:127:in `render'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/render/partials.rb:333:in `render_partial'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/render/partials.rb:262:in `render'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/notifications.rb:52:in `instrument'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/notifications/instrumenter.rb:21:in `instrument'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/notifications.rb:52:in `instrument'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/render/partials.rb:260:in `render'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/render/partials.rb:378:in `_render_partial'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/render/rendering.rb:22:in `render_without_haml'
 /usr/lib/ruby/gems/1.8/gems/haml-3.1.2/lib/haml/helpers/action_view_mods.rb:11:in `render'
 /usr/lib/ruby/gems/1.8/gems/haml-3.1.2/lib/haml/helpers.rb:90:in `non_haml'
 /usr/lib/ruby/gems/1.8/gems/haml-3.1.2/lib/haml/helpers/action_view_mods.rb:11:in `render'
 /usr/share/aeolus-conductor/app/views/pools/_new.html.haml:8:in `_app_views_pools__new_html_haml___1462581414_70237638997460_67230'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/template.rb:135:in `send'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/template.rb:135:in `render'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/notifications.rb:54:in `instrument'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/template.rb:127:in `render'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/render/partials.rb:333:in `render_partial'
 /usr/lib/ruby/gems/1.8/gems/actionpack-3.0.10/lib/action_view/render/partials.rb:262:in `render'
 /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/notifications.rb:52:in `instrument'
Comment 1 Shveta 2012-03-27 04:30:27 EDT
OK this is same as https://bugzilla.redhat.com/show_bug.cgi?id=803647 

My bug is space at the end of zone name should be trimmed and it should not allow to create duplicate pools

Steps :
Create a zone new_zone , create another zone new_zone (space at the end)
Two pools will be created with the name new_zone
Comment 2 Shveta 2012-03-27 04:32:02 EDT
Created attachment 572976 [details]
new_zone
Comment 4 Dave Johnson 2012-12-12 16:50:14 EST

*** This bug has been marked as a duplicate of bug 864223 ***

Note You need to log in before you can comment on or make changes to this bug.