Bug 807145 - Can not define xml with 232 disks with multifunction
Can not define xml with 232 disks with multifunction
Status: CLOSED DUPLICATE of bug 808980
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Michal Privoznik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 03:38 EDT by weizhang
Modified: 2012-06-01 09:22 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-01 09:22:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest xml with 232 usb disks (64.82 KB, text/plain)
2012-03-27 03:38 EDT, weizhang
no flags Details

  None (edit)
Description weizhang 2012-03-27 03:38:05 EDT
Created attachment 572957 [details]
guest xml with 232 usb disks

Description of problem:
I try to test multifunction so I create a xml with 232 disks with multifunction, when do define, it report error
# virsh define usb-all.xml 
error: Failed to define domain from usb-all.xml
error: Unable to encode message payload
error: Reconnected to the hypervisor

if I remove 3 disks, then define can be succeed, but when do dumpxml, it still report error 
# virsh dumpxml usb
error: Unable to encode message payload
error: Reconnected to the hypervisor

Version-Release number of selected component (if applicable):
libvirt-0.9.10-8.el6.x86_64
kernel-2.6.32-250.el6.x86_64
qemu-kvm-0.12.1.2-2.262.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Define a guest with xml in attachment
# virsh define guest.xml
2.
3.
  
Actual results:
Report error

Expected results:
Should succeed both for define and dumpxml

Additional info:
Comment 1 Daniel Berrange 2012-03-27 05:34:26 EDT
The XML file is 66375 bytes long, and our maximum RPC string size is 65536 bytes. When dumping the XML file, it will grow as libvirt adds in various default attributes.
Comment 2 Dave Allan 2012-03-27 13:56:11 EDT
So what does a user with such a VM do?
Comment 4 Ronen Hod 2012-03-28 12:44:48 EDT
Note that until we support PCI bridge it might also be related to
https://bugzilla.redhat.com/show_bug.cgi?id=753692
Comment 5 Dave Allan 2012-04-26 15:33:40 EDT
Michal, I think this can be closed as a dup of one of the other BZs in which the maximum RPC size was exceeded, but I'll leave that up to you.
Comment 6 Michal Privoznik 2012-06-01 09:22:14 EDT
Yes. This is definitely a dup of bug 808980 and bug 797279. Therefore I am closing this one.

*** This bug has been marked as a duplicate of bug 808980 ***

Note You need to log in before you can comment on or make changes to this bug.