Bug 807148 - can't enable wireless
can't enable wireless
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 03:47 EDT by Karel Volný
Modified: 2012-07-18 13:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 13:55:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2012-03-27 03:47:29 EDT
Description of problem:
After booting F17 Alpha live, I'm unable to conenct to wifi. Trying to "enable wireless" fails.

Version-Release number of selected component (if applicable):
kde-plasma-networkmanagement-0.9-0.70.rc4.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. click networkmanagement icon in systray
2. check "Enable wireless"
  
Actual results:
the checkmark disappears a few seconds after checking the option, WLAN Interface has status "unavailable"

NO ERROR MESSAGE IS REPORTED IT JUST FAILS SILENTLY!


Expected results:
wifi works as usual; if it cannot be activated for some reason, the user should get an error message stating the reason

Additional info:
from lspci
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n/ Wireless LAN controller (rev 01)
Comment 1 Martin Bříza 2012-07-17 11:21:59 EDT
I'm sorry if this question insults you, but: Don't you remember if you had wifi turned off by some sort of switch on your laptop? I'm just asking because these two upstream reports seem to be related:
https://bugs.kde.org/show_bug.cgi?id=225115
https://bugs.kde.org/show_bug.cgi?id=268990
Please, also check if this still happens because it is quite a while after the report.
Thank you.
Comment 2 Karel Volný 2012-07-18 06:26:54 EDT
oh, I've forgotten about this report ...

from what I recall, the problem was that there had been some bug in the Broadcom driver in Alpha which got fixed by a newer kernel

so the wifi wasn't working because of that bug, no "airplane mode" switch or so

as for https://bugs.kde.org/show_bug.cgi?id=225115 - this was different bug that I've experienced a few Fedora versions ago - coincidentally, I happened to re-test this recently and I can no longer reproduce the problem in F17

as for https://bugs.kde.org/show_bug.cgi?id=268990 - I see no real difference to 225115 ... it is something else than this report

but ... even if the kernel update fixed the issue for me, I think there is still a problem in KNetworkManager which should be fixed (unless already done under another bug number) - the problem is that KNetworkManager should report an error message, if the connection fails, and that it should not allow to "activate" an interface which it cannot activate (note that activate != connect to a network)

I'm not sure how to test this reliably (you won't fiddle with faulty kernel ...), but I believe that simply turning the wifi off, if the machine has the switch (which is not my case, unfortunately), should do the trick
Comment 3 Martin Bříza 2012-07-18 06:42:37 EDT
I've got this switch on Lenovo Thinkpad T520 and when I switch it off, the "Enable wireless" selection becomes gray and can't be activated so as for this issue, it was fixed.
I, however, don't know if it covers every problem in this report...
Comment 4 Kevin Kofler 2012-07-18 13:55:54 EDT
I think we should close this, we can reopen it if somebody can reproduce any of the issues raised here.

Note You need to log in before you can comment on or make changes to this bug.