This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 807170 - Add systemd units for the replicator, updater and auditor services
Add systemd units for the replicator, updater and auditor services
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openstack-swift (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Pete Zaitcev
Fedora Extras Quality Assurance
:
: 872339 (view as bug list)
Depends On:
Blocks: 863974
  Show dependency treegraph
 
Reported: 2012-03-27 04:23 EDT by Derek Higgins
Modified: 2013-01-08 14:42 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 14:41:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Derek Higgins 2012-03-27 04:23:25 EDT
An installation of openstack-shift from EPEL includes init scripts for the main services
'proxy-server', 'account-server', 'container-server' and 'object-server'

should we also include

'account-auditor', 'container-auditor', 'container-replicator', 'container-sync',
'container-updater', 'object-auditor', 'object-expirer', 'object-replicator', 
'object-updater', 'account-replicator', 'account-reaper'

most of these use the same config files already required for the main servers
Comment 1 Jasper Capel 2012-05-10 04:24:29 EDT
I think those init scripts should be added, as Swift doesn't work well at all without those services.
Comment 2 Mark McLoughlin 2012-10-08 04:36:38 EDT
Moving to Fedora since we should add systemd units first and then add the equivalent init scripts in EPEL
Comment 3 Derek Higgins 2012-11-05 05:30:53 EST
*** Bug 872339 has been marked as a duplicate of this bug. ***
Comment 4 Joseph W. Breu 2012-11-05 17:36:19 EST
Hi Derek,

Has any work been completed to add init scripts for the additional services to the openstack-swift packages?

-breu
Comment 5 Pete Zaitcev 2012-11-05 20:26:29 EST
I wrote and committed unit files for Fedora but not extra scripts for EPEL.
For now the workaround remains putting invocations of swift-init in rc.local.
Comment 6 Pete Zaitcev 2013-01-08 14:41:49 EST
Fixed in openstack-swift-1.7.4-2.fc19 (delivered in subpackages for
proxy, account, container, object). Closing.
Comment 7 Pete Zaitcev 2013-01-08 14:42:18 EST
Track progress of init scripts for RHOS in bug 885530.

Note You need to log in before you can comment on or make changes to this bug.