Bug 807250 - pass-through Multimedia Speaker device to the windows guest with spice console fail to work
pass-through Multimedia Speaker device to the windows guest with spice consol...
Status: CLOSED DUPLICATE of bug 807878
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 07:12 EDT by Sibiao Luo
Modified: 2012-03-30 04:58 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 04:58:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2012-03-27 07:12:58 EDT
Description of problem:
boot a windows 7 guest and passthrough a Multimedia Speaker device to the guest with spice console, and then play sound inside kvm guest, but the Multimedia Speaker fail to work, we cann't hear anything.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-251.el6.x86_64
qemu-kvm-0.12.1.2-2.265.el6.x86_64
# rpm -q seabios
seabios-0.6.1.2-12.el6.x86_64 
guest info:
guest_name: win7sp1-64
virtio-win: virtio-win-prewhql-0.1-24

How reproducible:
100%

Steps to Reproduce:
1.plug the Multimedia Speaker to the host and get USB device info var "lsusb".
# lsusb
Bus 002 Device 015: ID 0c76:160c JMTek, LLC.
2.boot a windows 7 guest and passthrough a Multimedia Speaker device to the guest with spice console.
CLI: # /usr/libexec/qemu-kvm -M rhel6.3.0 -cpu Penryn -enable-kvm -m 2048 -smp 2,sockets=1,cores=2,threads=1 -name win7-sp1-64 -uuid `uuidgen` -drive file=/home/win7sp1-virtio-64-copy.raw,format=raw,if=none,id=drive-virtio-disk0,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,scsi=off,bus=pci.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup,downscript=no -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=05:1a:4a:02:0b:46,bus=pci.0,bootindex=2 -device virtio-balloon-pci,id=ballooning -spice disable-ticketing,port=5931 -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -monitor stdio -device intel-hda -device hda-duplex -usb -device usb-host,hostbus=2,hostaddr=15,id=hostdev1,bus=usb.0,port=1
3.play sound inside kvm guest and check the Multimedia Speaker.
example: select many songs online playing from www.9k.com
4.verify the device is present in guest from "Device Manager".

Actual results:
after the step 3, the Multimedia Speaker fail to work, we cann't hear anything from the Multimedia Speaker. 
after the step 4, we can find "High Definition Audio Device" and "USB Speaker" from "Device Manager" in the guest.

Expected results:
the Multimedia Speaker can work well and we can hear the music sounds smoothly.

Additional info:
Comment 1 Sibiao Luo 2012-03-27 07:15:58 EDT
(In reply to comment #0)
>
> 3.play sound inside kvm guest and check the Multimedia Speaker.
> example: select many songs online playing from www.9k.com
> 
sorry for my mistake, select many songs online playing from http://www.9ku.com/
Comment 5 Gerd Hoffmann 2012-03-30 04:58:01 EDT

*** This bug has been marked as a duplicate of bug 807878 ***

Note You need to log in before you can comment on or make changes to this bug.