Bug 807251 - Builtin microphone of Thinkpad x201 unavailable
Builtin microphone of Thinkpad x201 unavailable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 07:13 EDT by Ulrich Drepper
Modified: 2012-06-13 14:50 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 10:45:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2012-03-27 07:13:21 EDT
Description of problem:
After updating to the 3.3.0-4 kernel (64-bit, of course) on a Thinkpad x201 the microphone stopped working.  Looking at the audio system settings shows the built-in microphone but no level changes are indicated.

Reverting to the 3.2.9-* kernel solves the issue.

Version-Release number of selected component (if applicable):
3.3.0-4.x86_64

How reproducible:
always

Steps to Reproduce:
1.Boot 3.30 kernel on Thinkpad x201
2.Try recoding audio
3.
  
Actual results:
no microphone output

Expected results:
well, working microphone

Additional info:
Comment 1 Kristian Karl 2012-03-27 11:49:55 EDT
I can confirm this bug on my Thinkpad X201 as described above.
Works on 3.2.10-3.fc16.x86_64
Fails on 3.3.0-4.fc16.x86_64
Comment 2 Jon Phillips 2012-04-08 23:05:53 EDT
I can confirm this bug as well, same as Kristian.
Comment 3 Kristian Karl 2012-04-09 01:35:43 EDT
The problem still exists in 3.3.1-3.fc16.x86_64
Comment 4 Mike Reid 2012-04-15 01:41:12 EDT
I find the same on my Thinkpad T510. Mic works with none of the 3.3 kernels, but does work with the 3.2 kernels.
Comment 5 Josh Boyer 2012-04-15 10:22:24 EDT
If you load the snd-intel-hda module with 'model=thinkpad' it should work again.

We're working with upstream to fix this in the 3.3.x kernels.  If you would be so kind as to try this scratch kernel and let us know if it works or not:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3989218
Comment 6 Kristian Karl 2012-04-15 15:19:37 EDT
Yes, thanx, it worked just fine!
Comment 7 Josh Boyer 2012-04-16 09:39:38 EDT
(In reply to comment #6)
> Yes, thanx, it worked just fine!

Just to be clear, which worked?  The scratch build or the model= option?

If it was the scratch build, could you please attach the output of alsa-info?
Comment 8 Kristian Karl 2012-04-16 09:45:05 EDT
The model=thinkpad worked for me.

I added options "snd-hda-intel model=thinkpad" to the end of the file /etc/modprobe.d/dist-alsa.conf
Comment 9 Josh Boyer 2012-04-16 10:09:34 EDT
(In reply to comment #8)
> The model=thinkpad worked for me.

OK.  If you have a chance, could you please test the scratch build without that option set?
Comment 10 Kristian Karl 2012-04-16 14:28:25 EDT
Good news. I tested the scratch build without that option set, and the mic works.

I noticed though, that the mic volume was lower using the scratch build, than using normal kernel (3.3.1-3.fc16.x86_64), no other differences than the kernel version and option model=thinkpad.
Comment 11 Mike Reid 2012-05-09 15:39:34 EDT
I was unclear to me how exactly how to implement the above advice, so have been just trying out new kernels as they come out. With the latest 
kernel-PAE 3.3.4.3.fc16 i686
the mic does work, but is much too quiet. 

With 
kernel-PAE 3.2.10-3.fc16 i686
the mic works fine. 

Model: Lenovo T510
Comment 12 Ulrich Drepper 2012-05-12 12:16:06 EDT
Seems to work here as well.  The mic is quiet as well but at least it works.  Not sure whether you want a new bug about the volume level.
Comment 13 Mike Reid 2012-05-12 16:49:32 EDT
From my point of view it is the same bug, in that the mic is unusable for Skype, etc.
Comment 14 Mike Reid 2012-05-13 02:48:35 EDT
OK, latest kernel: 3.3.5-2 now has reasonable volume.
Comment 15 Josh Boyer 2012-05-14 10:45:58 EDT
3.3.5 contains the patch in the scratch build.
Comment 16 Dennis Appelon Nielsen 2012-05-15 16:06:13 EDT
Hi all the:

I added options "snd-hda-intel model=thinkpad" to the end of the file
/etc/modprobe.d/dist-alsa.conf

Fixed the problem for me on my Lenovo W510
running kernel-3.3.5-2.fc16.x86_64
Comment 17 Igor Bukanov 2012-06-03 14:23:26 EDT
The kernel update on my X201 notebook has not solved the problem, the microphone still does not work. I also tried to add to the end of /etc/modprobe.d/dist-alsa.conf :

options "snd-hda-intel model=thinkpad"

That did not help either. After checking with LiveCD that on Fedora 17 the microphone does work, I decided to upgrade to F17 using preupgradde. But that did not help. The microphone still does not work.

Should I file a new bug about that?
Comment 18 Ulrich Drepper 2012-06-13 14:50:40 EDT
The last couple of kernels do work on my x201 but without

  options snd-hda-intel model=thinkpad

the volume is too low by far.

Note You need to log in before you can comment on or make changes to this bug.