Bug 807304 - ipa permission-add throws internal server error when name contains '<' or '>'
ipa permission-add throws internal server error when name contains '<' or '>'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 09:15 EDT by Namita Soman
Modified: 2013-08-19 10:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: ipa-2.2.0-9.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:25:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached error indicated in /var/log/httpd/error_log (2.67 KB, text/plain)
2012-03-27 10:26 EDT, Namita Soman
no flags Details

  None (edit)
Description Namita Soman 2012-03-27 09:15:22 EDT
Description of problem:
Adding a permission with name containing '<' or '>' throws error:
ipa: ERROR: cannot connect to u'http://qe-blade-13.testrelm.com/ipa/xml': Internal Server Error


Version-Release number of selected component (if applicable):
ipa-server-2.2.0-5.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Add a permission with name "a<a" or "a>a"
ipa permission-add --permissions=write --attrs=description --type=user "a>a"

Actual results:
Got error:
ipa: ERROR: cannot connect to u'http://qe-blade-13.testrelm.com/ipa/xml': Internal Server Error


Expected results:
If there are characters that are not allowed in permission names, an error message indicating that should be thrown.

Additional info:

Attached
Comment 2 Martin Kosek 2012-03-27 09:32:42 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2585
Comment 3 Namita Soman 2012-03-27 10:26:20 EDT
Created attachment 573079 [details]
attached error indicated in /var/log/httpd/error_log
Comment 4 Rob Crittenden 2012-04-10 14:08:06 EDT
Fixed upstream

master: 6e5c8b25bffa2b62a2233c0347c2ed3dd081d4a9

ipa-2-2: 04427136b097daebedbb08532c935f605b908905

Only letters, numbers, -, _, and space are allowed.
Comment 8 Martin Kosek 2012-04-25 06:54:17 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 9 Namita Soman 2012-04-26 08:02:05 EDT
Verified using ipa-server-2.2.0-11.el6.x86_64

Executing: ipa permission-add Test<Permission --permissions="write" --type=user --attr=carlicense,description 
ipa: ERROR: invalid 'name': May only contain letters, numbers, -, _, and space
Comment 11 errata-xmlrpc 2012-06-20 09:25:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.