Bug 807371 - migration: don't append basedn to container if it is included
migration: don't append basedn to container if it is included
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 11:43 EDT by Dmitri Pal
Modified: 2015-01-05 06:05 EST (History)
3 users (show)

See Also:
Fixed In Version: ipa-2.2.0-10.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:25:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-03-27 11:43:52 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2566

When specifying a container to ds-migrate we should not automatically append the basedn if it is provided by the end-user.
Comment 3 Rob Crittenden 2012-04-17 15:36:37 EDT
Fixed upstream.

master: 72efa64c81fc44dbc05c48730c339120888fecbe

ipa-2-2: 36eb2543c3c01a24a6604b761b7287ae179cea7e
Comment 7 Jenny Galipeau 2012-04-23 12:21:13 EDT
verified ::

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: bz807371 migration: don't append basedn to container if it is included
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: EXECUTING: ipa migrate-ds --with-compat --user-container="ou=People,dc=example,dc=com" --group-container="ou=groups,dc=example,dc=com" ldap://dhcp-187-227.testrelm.com:389
:: [   PASS   ] :: Running 'echo Secret123 | ipa migrate-ds --with-compat --user-container="ou=People,dc=example,dc=com" --group-container="ou=groups,dc=example,dc=com" ldap://dhcp-187-227.testrelm.com:389'
:: [   PASS   ] :: Verifying puser1 was migrated
:: [   PASS   ] :: Verifying 'puser2' was migrated
:: [   PASS   ] :: Verifying 'philomena_hazen' was migrated
:: [   PASS   ] :: Verifying group 'group1' was migrated
:: [   PASS   ] :: Verifying group 'group2' was migrated
:: [   LOG    ] :: Cleaning up migrated users
:: [   LOG    ] :: Duration: 19s
:: [   LOG    ] :: Assertions: 6 good, 0 bad
:: [   PASS   ] :: RESULT: bz807371 migration: don't append basedn to container if it is included

version ::

ipa-server-2.2.0-10.el6.x86_64
Comment 9 Martin Kosek 2012-04-25 07:03:16 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 11 errata-xmlrpc 2012-06-20 09:25:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.