Bug 807389 - Video is in shade of blue when playing in guest hosted on RHEL5.8 host
Summary: Video is in shade of blue when playing in guest hosted on RHEL5.8 host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-27 16:30 UTC by Marian Krcmarik
Modified: 2012-06-20 12:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Playing video on guest hosted with RHEL5. Consequence: The video is tinted in blue on the client side. Fix: Use correct color conversion with older Spice server. Result: The video is tinted correctly with guests running on RHEL5 host.
Clone Of:
Environment:
Last Closed: 2012-06-20 12:19:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
blued video (665.32 KB, image/png)
2012-03-27 16:30 UTC, Marian Krcmarik
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0767 0 normal SHIPPED_LIVE spice-gtk bug fix and enhancement update 2012-06-19 19:30:09 UTC

Description Marian Krcmarik 2012-03-27 16:30:41 UTC
Created attachment 573120 [details]
blued video

Description of problem:
Video is in shade of blue when playing in guest hosted on RHEL5.8 host, It does on happen when guest is hosted on RHEL6.3, and It does on happen with spicec when host is either RHEL5.8 or RHEL6.3. See attachment for example. The background on played video should be in shade of gold solor.

Version-Release number of selected component (if applicable):
spice-glib-0.11-5.el6.x86_64
spice-gtk-tools-0.11-5.el6.x86_64
spice-gtk-0.11-5.el6.x86_64
spice-gtk-python-0.11-5.el6.x86_64
virt-viewer-0.5.2-3.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Connect to a guest hosted on RHEL5.8 host.
2. Play video
  
Actual results:
Video is in shade of blue

Expected results:
native colours of video.

Additional info:

Comment 2 Vaclav Ehrlich 2012-03-28 15:39:59 UTC
RHEL 6.3 host/Window 7 32bit guest
Red Dwarf video in VLC looks like The Smurfs

Comment 3 Lubos Kocman 2012-03-28 16:59:08 UTC
RHEL 5.8 host with remote-viewer and RHEL 6.3 guest

virt-viewer-0.5.2-3.el6.x86_64
spice-gtk-0.11-5.el6.x86_64

Comment 6 Marc-Andre Lureau 2012-03-30 21:47:39 UTC
fixed, patch sent to ML for review

Comment 12 Marc-Andre Lureau 2012-04-20 13:22:03 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.

Comment 13 Marc-Andre Lureau 2012-04-20 13:44:47 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1,11 @@
-No documentation needed.+Cause:
+Playing video on guest hosted with RHEL5.
+
+Consequence:
+The video is tinted in blue on the client side.
+
+Fix:
+Use correct color conversion with older Spice server.
+
+Result:
+The video is tinted correctly with guests running on RHEL5 host.

Comment 15 errata-xmlrpc 2012-06-20 12:19:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0767.html


Note You need to log in before you can comment on or make changes to this bug.