Bug 807392 - [fix available] Focus issues with pop-out preference panes
[fix available] Focus issues with pop-out preference panes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Caolan McNamara
Desktop QE
:
Depends On:
Blocks: 670971
  Show dependency treegraph
 
Reported: 2012-03-27 12:38 EDT by Matthew Mosesohn
Modified: 2013-01-10 08:07 EST (History)
2 users (show)

See Also:
Fixed In Version: libreoffice-3.4.5.2-12.el6
Doc Type: Bug Fix
Doc Text:
Cause: Wrong windowing system flags used on some floating dialogs Consequence: After switching focus from one document to another while the floating color dialog is open, it becomes impossible to type into the second document unless the floating dialog is close. Fix: Set the correct window manager decoration flags Result: Now possible to switch between documents, while the floating dialogs are active, and interact directly with the visible document
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:53:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of focus bug (4.76 MB, video/ogg)
2012-03-27 12:38 EDT, Matthew Mosesohn
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 48096 None None None Never

  None (edit)
Description Matthew Mosesohn 2012-03-27 12:38:29 EDT
Created attachment 573122 [details]
Example of focus bug

Description of problem:
If you expand a preference pane into a window, such as the Background Color one, you can't switch focus to another Calc spreadsheet and input there.

Version-Release number of selected component (if applicable):
libreoffice-3.4.5.2-5.el6.x86_64

How reproducible:
Always on RHEL 6 and Fedora 16

Steps to Reproduce:
1. Create a spreadsheet
2. Create another spreadsheet (Ctrl + n)
3. Expand "Background Color" preference
4. Click and drag Background Color down away from the toolbar to make it a window
5. Select Cell A1
6. Click the Red color in the Background Color window
7. Switch focus to the other spreadsheet
8. Select Cell A1
9. Try to input text
  
Actual results:
Input continues to be handled on the spreadsheet which opened the Background Color dialog

Expected results:
The input should be possible on the other spreadsheet while this dialog is open.

Additional info:
This applies to the following preference panes: Borders, Background Color, and Font Color
This doesn't affect Styles.
This doesn't affect interaction with LibreOffice Writer documents

See attached screencast as an example of the bug.
Comment 2 Caolan McNamara 2012-03-27 16:13:10 EDT
I can reproduce it anyway. However these focus problems + various window managers are a tricky business to mess with e.g. add a metacity workaround and kwin falls over, so if this turns out to not be a regression from rhel-6.2 oopenoffice.org  I'd be far more comfortable moving it to e.g. a rhel-7 target.
Comment 3 Matthew Mosesohn 2012-03-27 16:46:58 EDT
Caolan,

This is indeed a regression from OOo 3.2 from RHEL 6.2.
Comment 4 Caolan McNamara 2012-03-29 07:40:55 EDT
http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=46ea2f6cb38536aa1b1a259af2145a581e19f6e8 is the regression itself. What that fixes though is that clicking the color popdowns creates toplevel windows immediately, rather down dropdowns.
Comment 6 Caolan McNamara 2012-04-02 16:02:55 EDT
Old behaviour is pretty awful too, albeit better than current behaviour. 

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a482b89e4d9c41b6f7c1616d193ac6cde05a69a7 appears to work to give the full-desired behaviour
Comment 10 Caolan McNamara 2012-05-01 06:12:51 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Wrong windowing system flags used on some floating dialogs

Consequence: After switching focus from one document to another while the floating color dialog is open, it becomes impossible to type into the second document unless the floating dialog is close.

Fix: Set the correct window manager decoration flags

Result: Now possible to switch between documents, while the floating dialogs are active, and interact directly with the visible document
Comment 13 errata-xmlrpc 2012-06-20 08:53:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0798.html

Note You need to log in before you can comment on or make changes to this bug.