Bug 807404 - munin-node is compiled to use /etc/opt/munin/munin-node.conf but should use /etc/munin/munin-node.conf
munin-node is compiled to use /etc/opt/munin/munin-node.conf but should use /...
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: munin (Show other bugs)
el6
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 13:15 EDT by Mark Waterhouse
Modified: 2012-03-29 08:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-29 08:19:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (101.51 KB, text/plain)
2012-03-29 06:38 EDT, Mark Waterhouse
no flags Details

  None (edit)
Description Mark Waterhouse 2012-03-27 13:15:59 EDT
Description of problem:
On a fresh munin-node installation, /usr/sbin/munin-node looks for the configuration file in /etc/opt/munin.
However, the referenced file (and the one which is packaged) is in /etc/munin/

Version-Release number of selected component (if applicable):
1.4.6-4.el6.2

How reproducible:
Everytime

Steps to Reproduce:
1. Install munin-node
2. Try to start /usr/sbin/munin-node
  
Actual results:
Fails to start

Expected results:
Process backgrounded

Additional info:
Comment 1 Kevin Fenzi 2012-03-27 13:37:12 EDT
I cannot duplicate this here. 

Do you perhaps have an older version installed from source? 

rpm -q munin-node munin-common
and
rpm -V munin-node munin-common

output please?
Comment 2 Mark Waterhouse 2012-03-27 13:56:18 EDT
I certainly did do originally....but I removed all references to the old munin before starting

[root@cust056-web01 ~]# rpm -q munin-node munin-common
munin-node-1.4.6-4.el6.2.noarch
munin-common-1.4.6-4.el6.2.noarch
[root@cust056-web01 ~]# rpm -V munin-node munin-common
[root@cust056-web01 ~]#

[root@cust056-web01 ~]# ls -l /usr/sbin/munin-node
-r-xr-xr-x. 1 root root 6778 Sep 12  2011 /usr/sbin/munin-node
[root@cust056-web01 ~]# sum /usr/sbin/munin-node
42424     7

[root@cust056-web01 ~]# strace /usr/sbin/munin-node

<snip>
chdir("/")                              = 0
stat("/usr/local/sbin", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat("/usr/local/bin", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat("/sbin", {st_mode=S_IFDIR|0555, st_size=12288, ...}) = 0
stat("/bin", {st_mode=S_IFDIR|0555, st_size=4096, ...}) = 0
stat("/usr/sbin", {st_mode=S_IFDIR|0555, st_size=4096, ...}) = 0
stat("/usr/bin", {st_mode=S_IFDIR|0555, st_size=20480, ...}) = 0
stat("/root/bin", 0x7fff20b94e30)       = -1 ENOENT (No such file or directory)
open("/etc/opt/munin/munin-node.conf", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/locale.alias", O_RDONLY) = 4
fstat(4, {st_mode=S_IFREG|0644, st_size=2512, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f5c6f817000
read(4, "# Locale name alias data base.\n#"..., 4096) = 2512
read(4, "", 4096)                       = 0
close(4)                                = 0
</snip>




<snip>
mmap(0x7f5c674af000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 4, 0x8000) = 0x7f5c674af000
close(4)                                = 0
write(2, "ERROR: Cannot open '/etc/opt/mun"..., 111ERROR: Cannot open '/etc/opt/munin/munin-node.conf': No such file or directory at /usr/sbin/munin-node line 73
) = 111
lseek(3, 4776, SEEK_SET)                = 4776
lseek(3, 0, SEEK_CUR)                   = 4776
close(3)                                = 0
exit_group(2)
</snip>
Comment 3 Kevin Fenzi 2012-03-27 14:31:14 EDT
Please check /etc/munin/munin-node.conf 

does it have any 'opt' in it?
Comment 4 Mark Waterhouse 2012-03-27 17:42:19 EDT
no, for the sake of testing, I just used the munin-node.conf as distributed by the package.
Comment 5 Kevin Fenzi 2012-03-27 18:39:58 EDT
Can you attach the full strace -f output?
Comment 6 Mark Waterhouse 2012-03-29 06:38:56 EDT
Created attachment 573620 [details]
strace output

output of 

# strace -f /usr/sbin/munin-node
Comment 7 d. johnson 2012-03-29 08:00:00 EDT
What provided these files?

open("/usr/local/share/perl5/Munin/Node/Config.pm", O_RDONLY) = 4
open("/usr/local/share/perl5/Munin/Common/Config.pm", O_RDONLY) = 5
open("/usr/local/share/perl5/Munin/Node/OS.pm", O_RDONLY) = 5
open("/usr/local/share/perl5/Munin/Common/Timeout.pm", O_RDONLY) = 6
open("/usr/local/share/perl5/Munin/Common/Defaults.pm", O_RDONLY) = 5
open("/usr/local/share/perl5/Munin/Node/Server.pm", O_RDONLY) = 4
open("/usr/local/share/perl5/Net/Server/Fork.pm", O_RDONLY) = 5
open("/usr/local/share/perl5/Net/Server.pm", O_RDONLY) = 6
open("/usr/local/share/perl5/Net/Server/Proto.pm", O_RDONLY) = 7
open("/usr/local/share/perl5/Net/Server/Daemonize.pm", O_RDONLY) = 7
open("/usr/local/share/perl5/Net/Server/SIG.pm", O_RDONLY) = 6
open("/usr/local/share/perl5/Munin/Common/TLSServer.pm", O_RDONLY) = 5
open("/usr/local/share/perl5/Munin/Common/TLS.pm", O_RDONLY) = 6
open("/usr/local/share/perl5/Munin/Node/Logger.pm", O_RDONLY) = 5
open("/usr/local/share/perl5/Munin/Node/Session.pm", O_RDONLY) = 5
open("/usr/local/share/perl5/Munin/Node/Utils.pm", O_RDONLY) = 5

Can you run:

rpm -qf /usr/local/share/perl5/Munin/*/*.pm /usr/local/share/perl5/Net/Server/*/*.pm
Comment 8 Mark Waterhouse 2012-03-29 08:19:37 EDT
[root@outbound-mx3 objects]# rpm -qf /usr/local/share/perl5/Munin/*/*.pm
file /usr/local/share/perl5/Munin/Common/Config.pm is not owned by any package
file /usr/local/share/perl5/Munin/Common/Defaults.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Common/DictFile.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Common/SyncDictFile.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Common/Timeout.pm is not owned by any package
file /usr/local/share/perl5/Munin/Common/TLSClient.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Common/TLS.pm is not owned by any package
file /usr/local/share/perl5/Munin/Common/TLSServer.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Master/Config.pm is not owned by any package
file /usr/local/share/perl5/Munin/Master/GraphOld.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Master/Group.pm is not owned by any package
file /usr/local/share/perl5/Munin/Master/GroupRepository.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Master/Host.pm is not owned by any package
file /usr/local/share/perl5/Munin/Master/HTMLConfig.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Master/HTMLOld.pm is not owned by any package
file /usr/local/share/perl5/Munin/Master/LimitsOld.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Master/Logger.pm is not owned by any package
file /usr/local/share/perl5/Munin/Master/Node.pm is not owned by any package
file /usr/local/share/perl5/Munin/Master/ProcessManager.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Master/Update.pm is not owned by any package
file /usr/local/share/perl5/Munin/Master/UpdateWorker.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Master/Utils.pm is not owned by any package
file /usr/local/share/perl5/Munin/Master/Worker.pm is not owned by any package
file /usr/local/share/perl5/Munin/Node/Config.pm is not owned by any package
file /usr/local/share/perl5/Munin/Node/Logger.pm is not owned by any package
file /usr/local/share/perl5/Munin/Node/OS.pm is not owned by any package
file /usr/local/share/perl5/Munin/Node/ProxySpooler.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Node/Server.pm is not owned by any package
file /usr/local/share/perl5/Munin/Node/Service.pm is not owned by any package
file /usr/local/share/perl5/Munin/Node/Session.pm is not owned by any package
file /usr/local/share/perl5/Munin/Node/SNMPConfig.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Node/SpoolReader.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Node/SpoolWriter.pm is not owned by any
package
file /usr/local/share/perl5/Munin/Node/Utils.pm is not owned by any package
file /usr/local/share/perl5/Munin/Plugin/Pgsql.pm is not owned by any package
file /usr/local/share/perl5/Munin/Plugin/SNMP.pm is not owned by any package


Aha - so, these files were left behind after a previous source install.


# yum remove munin-common munin-node

Lets clean them up
# cd /usr/local/share/perl5
# rm -rf Munin
# find /. -print | grep -i munin
/./root/munin-2.0-rc4.tar.gz
/./etc/selinux/targeted/modules/active/modules/munin.pp
/./var/lock/subsys/munin-node
/./usr/share/selinux/devel/include/services/munin.if
/./usr/share/selinux/targeted/munin.pp.bz2

# yum install munin-node

Can I now start it?
# /etc/init.d/munin-node start
Starting Munin Node:                                       [  OK  ]

[root@outbound-mx3 /]# ps -ef | grep munin
root     32151     1  0 08:17 ?        00:00:00 /usr/sbin/munin-node



Thank you Kevin
Not a bug....user error.....didnt clean up as well as I thought I had done from
the previous source install.

Note You need to log in before you can comment on or make changes to this bug.