Bug 807410 - Remote-viewer segfaults when migrating between RHEL5.8 host in RHEVM22 environment
Remote-viewer segfaults when migrating between RHEL5.8 host in RHEVM22 enviro...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 13:36 EDT by Marian Krcmarik
Modified: 2012-06-20 08:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:19:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core dump (5.83 MB, application/x-xz)
2012-03-27 13:36 EDT, Marian Krcmarik
no flags Details

  None (edit)
Description Marian Krcmarik 2012-03-27 13:36:13 EDT
Created attachment 573144 [details]
Core dump

Description of problem:
Remote-viewer segfaults when migrating between RHEL5.8 host in RHEVM22 environment
Log output:
Mar 27 19:15:55 dhcp-29-89 kernel: remote-viewer[22128]: segfault at 18 ip 0000003bc0a13e61 sp 00007fffaf92b450 error 4 in libglib-2.0.so.0.2200.5[3bc0a00000+e4000]
Mar 27 19:15:55 dhcp-29-89 abrt[22136]: abrt daemon is not running. If it crashed, /proc/sys/kernel/core_pattern contains a stale value, consider resetting it to 'core'
Mar 27 19:15:56 dhcp-29-89 abrt[22136]: saved core dump of pid 22128 to core.22128 (194265088 bytes)
Mar 27 19:15:56 dhcp-29-89 spice: remote-viewer execution failed

See core dump in attachment. 

Version-Release number of selected component (if applicable):
spice-glib-0.11-5.el6.x86_64
spice-gtk-tools-0.11-5.el6.x86_64
spice-gtk-0.11-5.el6.x86_64
spice-gtk-python-0.11-5.el6.x86_64
virt-viewer-0.5.2-3.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Connect with remote-viewer to guest hosted on RHEL5.8 hosts within RHEVM22
2. Migrate the guest
  
Actual results:
Segfault of remote-viewer in glib

Expected results:
Migrated guest

Additional info:
Comment 1 Marc-Andre Lureau 2012-03-30 15:38:05 EDT
Always easier with backtrace:

#0  0x0000003bc0a13e61 in g_array_unref () from /lib64/libglib-2.0.so.0
Missing separate debuginfos, use: debuginfo-install virt-viewer-0.5.2-3.el6.x86_64
(gdb) bt
#0  0x0000003bc0a13e61 in g_array_unref () from /lib64/libglib-2.0.so.0
#1  0x00007f5473dcfce9 in spice_session_set_property (gobject=0x414aac0, 
    prop_id=12, value=0x7fffaf92b5d0, pspec=0x2590140) at spice-session.c:479
#2  0x0000003bc0e104f2 in g_object_set_valist ()
   from /lib64/libgobject-2.0.so.0
#3  0x0000003bc0e10a94 in g_object_set () from /lib64/libgobject-2.0.so.0
#4  0x00007f5473de1f8f in migrate_connect (data=0x7f5468c9da50)
    at channel-main.c:1542
#5  0x0000003bc0a38f0e in g_main_context_dispatch ()
   from /lib64/libglib-2.0.so.0
#6  0x0000003bc0a3c938 in ?? () from /lib64/libglib-2.0.so.0
#7  0x0000003bc0a3cd55 in g_main_loop_run () from /lib64/libglib-2.0.so.0
#8  0x0000003c9ab4c307 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#9  0x000000000041bcb5 in main ()
(gdb) f 1
#1  0x00007f5473dcfce9 in spice_session_set_property (gobject=0x414aac0, 
    prop_id=12, value=0x7fffaf92b5d0, pspec=0x2590140) at spice-session.c:479
479        g_byte_array_unref(s->pubkey);


This got fixed upstream (and in fact fixes also 802574)

http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=9f7c12da84d63280767ba7175043bcb29404458d
Comment 4 Marc-Andre Lureau 2012-04-20 09:20:04 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 6 errata-xmlrpc 2012-06-20 08:19:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0767.html

Note You need to log in before you can comment on or make changes to this bug.