Bug 807414 - kdump test fails after switchting to summer time / daylight saving time
kdump test fails after switchting to summer time / daylight saving time
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
6.1
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Caspar Zhang
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 13:45 EDT by Rainer Koenig
Modified: 2013-07-03 03:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 13:18:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Koenig 2012-03-27 13:45:33 EDT
Description of problem:
Germany switched to summer time (CEST) last weekend. Last week I performed 32-bit kdump tests on a test system and they passed. Today I performed the same tests with 64-bit and I failed. 

Version-Release number of selected component (if applicable):
Actual version of v7 testsuite

How reproducible:
always

Steps to Reproduce:
1. Install RHEL 6.2
2. Set HW clock to UTC and time zone to Europe/Berlin
3. Perform local kdump test
  
Actual results:
The test fails. The logs say, that no crashdump in a good time window could be found in /var/crash. 

Expected results:
kdump should work, regardless of the time and timezone settings.

Additional info:
Looking into /var/crash shows that the crashdump file is always 1 hour advanced to the real time.

Meanwhile I managed to pass the test with the following time settings:
- System clock is running on UTC
- System time zone is GMT-1h.

Looks like the change to summertime was messing things up. ;-)
Comment 1 Caspar Zhang 2012-07-18 03:44:23 EDT
Hi Rainer, is this still an issue? IIRC, the problem should no longer exist several hours later after switched to summer time.
Comment 2 Rob Landry 2012-08-06 15:07:38 EDT
Hrm,  I'm pretty certain nothing in v7 is daylight aware.  But it's worth confirming the issue does self resolve after a few hours or is there a period of time (days weeks months) where the various time zones being at different offsets continues to effect the test?

Note You need to log in before you can comment on or make changes to this bug.