Bug 807450 - [abrt] [a11y][reproducible] comphelper::OPropertySetAggregationHelper::getFastPropertyValue
[abrt] [a11y][reproducible] comphelper::OPropertySetAggregationHelper::getFas...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephan Bergmann
Fedora Extras Quality Assurance
abrt_hash:6ecf332301622a66f77915eca33...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-27 15:59 EDT by euphonix2780
Modified: 2012-09-25 07:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 07:03:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (24.14 KB, text/plain)
2012-03-27 16:00 EDT, euphonix2780
no flags Details
File: backtrace (83.13 KB, text/plain)
2012-03-27 16:00 EDT, euphonix2780
no flags Details
Sample database (11.33 KB, application/vnd.oasis.opendocument.database)
2012-03-28 14:25 EDT, euphonix2780
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 32010 None None None 2012-09-25 07:23:21 EDT

  None (edit)
Description euphonix2780 2012-03-27 15:59:57 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --base file:///home/benno/Documents/Jeduthun%20-%20Muziekbibliotheek/Jeduthun.odb --splash-pipe=7
comment:        Clicking a List control on a Base form.
crash_function: __GI_raise
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.2.10-3.fc16.x86_64
pid:            4345
pwd:            /home/benno
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 6 (SIGABRT)
time:           di 27 mrt 2012 21:27:13 CEST
uid:            1000
username:       benno

backtrace:      Text file, 85122 bytes
dso_list:       Text file, 24721 bytes
maps:           Text file, 109172 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:HOSTNAME=euphonium
:LC_MONETARY=nl_NL.utf8
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=4333
:GPG_AGENT_INFO=/tmp/keyring-0EKEMa/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-2499-euphonium-libreoffice-16_TIME2657952
:HISTSIZE=1000
:XDG_SESSION_COOKIE=262708ea500288290b80e90400000010-1332873795.812775-1773791268
:GJS_DEBUG_OUTPUT=stderr
:LC_NUMERIC=nl_NL.utf8
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-0EKEMa
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=benno
:SSH_AUTH_SOCK=/tmp/keyring-0EKEMa/ssh
:USERNAME=benno
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1178,unix/unix:/tmp/.ICE-unix/1178
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-base.desktop
:MAIL=/var/spool/mail/benno
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/benno/.local/bin:/home/benno/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/benno
:XMODIFIERS=@im=none
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:LC_MEASUREMENT=nl_NL.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/benno
:XDG_SEAT=seat0
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=benno
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-XXcEDsvtK4,guid=b680671c91ba650dc130352a0000001e
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/benno
:DISPLAY=:0.0
:LC_TIME=nl_NL.utf8
:XAUTHORITY=/var/run/gdm/auth-for-benno-1m8mot/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64

var_log_messages:
:Mar 27 21:12:25 euphonium abrt[3103]: Saved core dump of pid 3045 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-03-27-21:12:20-3045 (585207808 bytes)
:Mar 27 21:13:01 euphonium abrt[3215]: Saved core dump of pid 3185 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-03-27-21:12:57-3185 (538038272 bytes)
:Mar 27 21:13:57 euphonium abrt[3319]: Saved core dump of pid 3269 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-03-27-21:13:52-3269 (588439552 bytes)
:Mar 27 21:23:01 euphonium abrt[3995]: Saved core dump of pid 3951 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-03-27-21:22:56-3951 (537665536 bytes)
:Mar 27 21:24:23 euphonium abrt[4177]: Saved core dump of pid 4116 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-03-27-21:24:17-4116 (590118912 bytes)
:Mar 27 21:27:17 euphonium abrt[4388]: Saved core dump of pid 4345 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-03-27-21:27:13-4345 (588009472 bytes)
Comment 1 euphonix2780 2012-03-27 16:00:01 EDT
Created attachment 573162 [details]
File: dso_list
Comment 2 euphonix2780 2012-03-27 16:00:04 EDT
Created attachment 573163 [details]
File: backtrace
Comment 3 David Tardon 2012-03-28 04:33:50 EDT
I cannot reproduce the crash. Could you attach the database file here?
Comment 4 euphonix2780 2012-03-28 14:25:03 EDT
Created attachment 573425 [details]
Sample database
Comment 5 euphonix2780 2012-03-28 14:28:46 EDT
I have attached a sample database which shows this behaviour on my system. The control on the form is a Table control and not a List control as I mentioned in the original bug report. My apologies for the confusion. Worked too much with MS Access last week I guess...
Comment 6 David Tardon 2012-03-29 06:52:24 EDT
I cannot reproduce the crash with the test database either. "Error: OPropertyArrayAggregationHelper::fillHandles : property names are not sorted!" looks suspicious, but it seems to be fixed in 3.5 .
Comment 7 euphonix2780 2012-03-31 09:15:16 EDT
Just installed version 3.5.1 from the libreoffice website, but the problem still exists.
Comment 8 David Tardon 2012-04-03 03:42:26 EDT
Oh, great, so these days it does not matter whether

gconftool-2 -g /desktop/gnome/interface/accessibility

says accessibility is enabled, if

gsettings get org.gnome.desktop.interface toolkit-accessibility

says it is not...

Reproducible now.
Comment 9 euphonix2780 2012-04-03 06:31:26 EDT
I needed my file this weekend and in order to be able to use it I decided to reinstall my system. With a fresh install the crash does not happen. I guess accessibility is disabled by default? I am at work and not able to check this at the moment.
Comment 10 Stephan Bergmann 2012-09-25 07:03:27 EDT
This is a duplicate of upstream <https://bugs.freedesktop.org/show_bug.cgi?id=32010> "AT enabled: LibO crashes when clicking a Table control body with control design mode off."  While that issue appears to be fixed in LO 3.6, it is unclear which individual commit actually fixed it there, so there is unfortunately no way to backport a fix to F-17's LO 3.5.  (F-18 includes LO 3.6, so this issue should at least be fixed there.)

Note You need to log in before you can comment on or make changes to this bug.