Bug 807477 - rhn-migrate-classic-to-rhsm is not throwing the expected errors for some negative tests
rhn-migrate-classic-to-rhsm is not throwing the expected errors for some nega...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
: Regression
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-27 17:35 EDT by John Sefler
Modified: 2012-06-20 09:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:08:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-03-27 17:35:52 EDT
Description of problem:
It appears that the fix for Bug 789007 is causing a regression in these three automated testcase scenarios:

_____________________________________

RhnMigrateClassicToRhsmWhileAlreadyRegisteredToRhsm_Test
expect -c "spawn rhn-migrate-classic-to-rhsm ; expect \"*Username:\"; send testuser1\ ; expect \"*Password:\"; send password\ ; interact; catch wait reason; exit [lindex \$reason 3]"
Stdout:
spawn rhn-migrate-classic-to-rhsm
RHN Username: testuser1
Password:
Problem encountered connecting to RHN Classic. Exiting.
Stderr:
ExitCode: 1
Test Failed: RhnMigrateClassicToRhsmWhileAlreadyRegisteredToRhsm_Test
java.lang.AssertionError: The expected stdout result from call to rhn-migrate-classic-to-rhsm while already registered to RHSM. contains matches to regex 'This machine appears to be already registered to Certificate-based RHN.  Exiting.' expected:<true> but was:<false>

_____________________________________

RhnMigrateClassicToRhsmWithInvalidCredentials_Test
ssh root@jsefler-63server.usersys.redhat.com expect -c "spawn rhn-migrate-classic-to-rhsm ; expect \"*Username:\"; send foo\ ; expect \"*Password:\"; send bar\ ; interact; catch wait reason; exit [lindex \$reason 3]"
Stdout:
spawn rhn-migrate-classic-to-rhsm
RHN Username: foo
Password:
Problem encountered connecting to RHN Classic. Exiting.
Stderr:
ExitCode: 1
Test Failed: RhnMigrateClassicToRhsmWithInvalidCredentials_Test
java.lang.AssertionError: The expected stdout result from call to rhn-migrate-classic-to-rhsm with invalid credentials. contains matches to regex 'Unable to connect to certificate server: Invalid Credentials.  See /var/log/rhsm/rhsm.log for more details.' expected:<true> but was:<false>

_____________________________________

RhnMigrateClassicToRhsmWithMissingSystemIdFile_Test
expect -c "spawn rhn-migrate-classic-to-rhsm ; expect \"*Username:\"; send testuser1\ ; expect \"*Password:\"; send password\ ; interact; catch wait reason; exit [lindex \$reason 3]"
Stdout:
spawn rhn-migrate-classic-to-rhsm
RHN Username: testuser1
Password:
Problem encountered connecting to RHN Classic. Exiting.
Stderr:
ExitCode: 1
Test Failed: RhnMigrateClassicToRhsmWithMissingSystemIdFile_Test
java.lang.AssertionError: The expected stdout result from call to rhn-migrate-classic-to-rhsm without having registered to RHN Classic. contains matches to regex 'Unable to locate SystemId file. Is this system registered?' expected:<true> but was:<false>

_____________________________________




Version-Release number of selected component (if applicable):
[root@jsefler-r63-server ~]# rpm -q subscription-manager-migration
subscription-manager-migration-0.99.12-1.git.1.2b349d3.el6.x86_64
Comment 2 Alex Wood 2012-03-30 12:50:47 EDT
Committed fd7c6760dac3caf25b76072a01c0e33445a32799

Available in subscription-manager-0.99.13+
Comment 4 Shwetha Kallesh 2012-04-03 07:01:15 EDT
verified!!

Version:

[root@dhcp201-196 pki]# rpm -qa | grep subscription-manager
subscription-manager-gnome-0.99.12-1.git.13.5a664a0.el6.x86_64
subscription-manager-firstboot-0.99.12-1.git.13.5a664a0.el6.x86_64
subscription-manager-migration-data-1.12.1.2-1.git.0.9e244c8.el6.noarch
subscription-manager-migration-0.99.12-1.git.13.5a664a0.el6.x86_64
subscription-manager-0.99.12-1.git.13.5a664a0.el6.x86_64

Invalid credentials:

[root@dhcp201-196 pki]# rhn-migrate-classic-to-rhsm
RHN Username: qa@redhat.com
Password: 
Unable to connect to certificate server: Invalid Credentials.  See /var/log/rhsm/rhsm.log for more details.

Already registered:

[root@dhcp201-196 pki]# rhn-migrate-classic-to-rhsm
RHN Username: qa@redhat.com
Password: 
This machine appears to be already registered to Certificate-based RHN.  Exiting.
Please visit https://access.redhat.com/management/consumers/175ffd23-8e75-4047-9f26-194a2d039bdc to view the profile details.

No systemid file:
[root@dhcp201-196 pki]# ls /etc/sysconfig/rhn/
allowed-actions  clientCaps.d  rhnsd  up2date


[root@dhcp201-196 pki]# rhn-migrate-classic-to-rhsm
RHN Username: qa@redhat.com
Password: 
Retrieving existing RHN Classic subscription information ...
Unable to locate SystemId file. Is this system registered?
Comment 6 errata-xmlrpc 2012-06-20 09:08:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.