Bug 807505 - qemu should have any tips when hotplugging duplicate vcpuid
qemu should have any tips when hotplugging duplicate vcpuid
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Igor Mammedov
Virtualization Bugs
:
Depends On:
Blocks: 833569
  Show dependency treegraph
 
Reported: 2012-03-27 22:09 EDT by FuXiangChun
Modified: 2012-07-26 06:13 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 06:13:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FuXiangChun 2012-03-27 22:09:54 EDT
Description of problem:
currently, qemu monitor haven't any tips.

Version-Release number of selected component (if applicable):
host kernel:
# uname -r
2.6.32-257.el6.x86_64

qemu vesion:
qemu-kvm-0.12.1.2-2.265.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1./usr/libexec/qemu-kvm -M rhel6.3.0 -cpu host --enable-kvm -m 4G -smp
1,maxcpus=161 -name rhel6.3 -uuid ddcbfb49-3411-1701-3c36-6bdbc00bedbb -rtc
base=utc,clock=host,driftfix=slew -drive
file=/dev/vg-54/lvtest,if=none,id=ide,format=qcow2,cache=none,werror=stop,rerror=stop
-device ide-drive,drive=ide,id=drive-ide0-0-0,bootindex=1 -netdev
tap,id=hostnet1 -device e1000,netdev=hostnet1,id=net1,mac=86:12:50:a4:32:72
-spice port=5911,disable-ticketing -vga qxl -device sga -chardev
socket,id=serial0,path=/var/test1,server,nowait -device
isa-serial,chardev=serial0 -balloon virtio -monitor
unix:/tmp/monitor2,server,nowait -monitor stdio

2.hotplug duplicate vcpu from monitor
cpu_set 0 online

3.
  
Actual results:
monitor haven't any warning message, and hotplug fail(guest don't get new cpu).

Expected results:
qemu have duplicate warning message. 

Additional info:
Comment 2 Igor Mammedov 2012-03-29 08:27:07 EDT
Attempt to hotplug already existing vcpu is a nop, it practically does nothing except of sending SCI to guest and guest checks for hot-plugged cpus and since cpu was already marked in bios as present, guest doesn't see anything to hot-plug.

Since it's not critical, I'd say ignore this for RHEL6.3 and implement/fix it upstream first.
Comment 4 RHEL Product and Program Management 2012-07-10 02:02:47 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 22:04:26 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Igor Mammedov 2012-07-26 06:13:25 EDT
Supported libvirt interface does it correctly, i.e. it doesn't try to hotplug existing vCPU. So fixing it for 6.3 is so not important and customers shouldn't be affected by it.
Closing it  as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.