Bug 807550 - [abrt] ibus-1.4.99.20120304-3.fc17: enginetreeview.py:133:__name_cell_data_cb:AttributeError: 'NoneType' object has no attribute 'get_language'
[abrt] ibus-1.4.99.20120304-3.fc17: enginetreeview.py:133:__name_cell_data_cb...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:3ace6c16889ab6825fdb593b81b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 02:27 EDT by Parag Nemade
Modified: 2012-08-08 20:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 05:19:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2012-03-28 02:27:09 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/share/ibus/setup/main.py ibus-setup
comment:        I just right click on ibus icon in gnome-shell to open ibus preferences and got abrt crash message.
executable:     /usr/share/ibus/setup/main.py
kernel:         3.3.0-1.fc17.x86_64
reason:         enginetreeview.py:133:__name_cell_data_cb:AttributeError: 'NoneType' object has no attribute 'get_language'
time:           Wed 28 Mar 2012 12:46:31 AM IST
uid:            1000
username:       parag

backtrace:
:enginetreeview.py:133:__name_cell_data_cb:AttributeError: 'NoneType' object has no attribute 'get_language'
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/setup/enginetreeview.py", line 133, in __name_cell_data_cb
:    language = IBus.get_language_name(engine.get_language())
:AttributeError: 'NoneType' object has no attribute 'get_language'
:
:Local variables in innermost frame:
:engine: None
:self: <EngineTreeView object at 0x11b52d0 (EngineTreeView at 0x12d4030)>
:celllayout: <TreeViewColumn object at 0x1379af0 (GtkTreeViewColumn at 0x12371a0)>
:it: <GtkTreeIter at 0x1631da0>
:renderer: <CellRendererText object at 0x1379b40 (GtkCellRendererText at 0x12a45a0)>
:model: <ListStore object at 0x11b5230 (GtkListStore at 0x12cd910)>
:data: None
Comment 1 fujiwara 2012-03-28 21:51:00 EDT
I tried the steps but I could not reproduce your problem with the latest Fedora 17.
Are you able to reproduce your problem with the new user account?

Also I suggest to use ibus-gnome3 on gnome-shell and the latest ibus-gnome3 does not show the link of ibus-setup so I'd expect to launch ibus-setup by command line or application menu.

% rpm -q ibus-gnome3
ibus-gnome3-1.4.99.20120317-2.fc17.x86_64
% rpm -q gnome-shell gjs
gnome-shell-3.3.92-1.fc17.x86_64
gjs-1.31.22-1.fc17.x86_64

(In reply to comment #0)
> :Traceback (most recent call last):
> :  File "/usr/share/ibus/setup/enginetreeview.py", line 133, in
> __name_cell_data_cb
> :    language = IBus.get_language_name(engine.get_language())
> :AttributeError: 'NoneType' object has no attribute 'get_language'

Is the engine is always None in __name_cell_data_cb() ?
Comment 2 stonewen@gmail.com 2012-08-04 23:11:45 EDT
rpm -q ibus-gnome3
ibus-gnome3-1.4.99.20120712-1.fc17.i686rpm -q gnome-shell gjs
gnome-shell-3.4.1-5.fc17.i686
gjs-1.32.0-1.fc17.i686
i update ibus to the lastest version but the problem is still.
because i use a old pc,i'm in gnome3 fallback mode,do you test in this mode?
Comment 3 fujiwara 2012-08-05 22:14:32 EDT
> because i use a old pc,i'm in gnome3 fallback mode,do you test in this mode?

Which old pc do you indicate?
I don't see any problems in both gnome-shell and the fallback mode.
I ask the same question here:
Is the engine is always None in __name_cell_data_cb() ?
Comment 4 stonewen@gmail.com 2012-08-08 11:08:00 EDT
i test again in gnome 3 fallback mode,and still something error,when i send the error,i find someone have send the same error in https://bugzilla.redhat.com/show_bug.cgi?id=827841
Comment 5 stonewen@gmail.com 2012-08-08 11:11:01 EDT
i'm not a programmer,so i don't know whether the engine is always None in __name_cell_data_cb()
Comment 6 fujiwara 2012-08-08 20:59:08 EDT
(In reply to comment #5)
> i'm not a programmer,so i don't know whether the engine is always None in
> __name_cell_data_cb()

This bug explains __name_cell_data_cb() has None object in the comment #0:

(In reply to comment #0)
> reason:         enginetreeview.py:133:__name_cell_data_cb:AttributeError:
> 'NoneType' object has no attribute 'get_language'
>
> backtrace:
> :enginetreeview.py:133:__name_cell_data_cb:AttributeError: 'NoneType' object
> has no attribute 'get_language'
> :

If you don't see the same error, your problem is not same and please open a new bug.

(In reply to comment #4)
> i test again in gnome 3 fallback mode,and still something error,when i send
> the error,i find someone have send the same error in
> https://bugzilla.redhat.com/show_bug.cgi?id=827841

Bug #827841 and this are different. bug #827841 explains __icon_cell_data_cb() has None object.
If you're not sure about the call back, please open a new bug instead of commenting different bugs.

Note You need to log in before you can comment on or make changes to this bug.