Bug 807551 - csprocessor 0.22 push explodes
csprocessor 0.22 push explodes
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 02:28 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.22.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-01 03:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CSProcessor project folder (5.72 KB, application/zip)
2012-03-28 02:29 EDT, Joshua Wulf
no flags Details

  None (edit)
Description Joshua Wulf 2012-03-28 02:28:28 EDT
cspclient-0.22.5-1.noarch
OS: Fedora release 16 (Verne)

JAVA: java version "1.7.0_b147-icedtea"
OpenJDK Runtime Environment (fedora-2.1.fc16.1-x86_64)
OpenJDK 64-Bit Server VM (build 22.0-b10, mixed mode)


[jwulf@nitai Content_Spec_Processor_Guide]$ csprocessor push
CSProcessor client version: 0.22.5
Loading configuration from /home/jwulf/.config/csprocessor.ini
Connecting to Skynet server: http://skynet.usersys.redhat.com:8080/TopicIndex/

INFO:  The Content Specification is valid.
INFO:  The Content Specification saved successfully.

Content Specification ID: 7210
Revision: 56403
Exception in thread "main" java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:58)
Caused by: java.lang.NullPointerException
	at com.redhat.contentspec.client.commands.PushCommand.process(PushCommand.java:180)
	at com.redhat.contentspec.client.Client.processArgs(Client.java:201)
	at com.redhat.contentspec.client.Client.main(Client.java:89)
	... 5 more
Comment 1 Joshua Wulf 2012-03-28 02:29:18 EDT
Created attachment 573244 [details]
CSProcessor project folder
Comment 2 Lee Newson 2012-03-28 02:44:10 EDT
Fixed in 0.22.6

Cause:
The program was trying to create the directories for the output file. However if the directory was the current working directory there was no parent and it threw a NullPointerException.

Consequence:
The program would crash and couldn't save the new Content Specification to the users file system. The server however was updated.

Fix:
Check if the parent is null, if it is then there isn't any need to try to create the directories.
Comment 3 Joshua Wulf 2012-05-01 03:48:04 EDT
Verified with 0.23.2-1

Note You need to log in before you can comment on or make changes to this bug.