Bug 807590 - virtual network looses network connection
virtual network looses network connection
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 810464
  Show dependency treegraph
 
Reported: 2012-03-28 05:21 EDT by Matěj Cepl
Modified: 2012-10-15 11:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-144.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 810464 (view as bug list)
Environment:
Last Closed: 2012-06-20 08:32:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2012-03-28 05:21:17 EDT
Description of problem:
After half a year hiatus or so, I have started again RHEL 5 VM on RHEL 6 host and VM cannot ping anywhere. DNS resolution works, but ping to www.google.com stalls.

In ausearch I found

----
time->Wed Mar 28 10:41:31 2012
type=SYSCALL msg=audit(1332924091.409:56026): arch=c000003e syscall=16 success=no exit=-13 a0=10 a1=400454ca a2=7f28bd06eb10 a3=b items=0 ppid=1 pid=26904 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="libvirtd" exe="/usr/sbin/libvirtd" subj=unconfined_u:system_r:virtd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1332924091.409:56026): avc:  denied  { relabelfrom } for  pid=26904 comm="libvirtd" scontext=unconfined_u:system_r:virtd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tclass=tun_socket
----
time->Wed Mar 28 10:42:09 2012
type=SYSCALL msg=audit(1332924129.623:56029): arch=c000003e syscall=16 success=no exit=-13 a0=15 a1=400454ca a2=7f28c38ae970 a3=b items=0 ppid=1 pid=26895 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="libvirtd" exe="/usr/sbin/libvirtd" subj=unconfined_u:system_r:virtd_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1332924129.623:56029): avc:  denied  { relabelfrom } for  pid=26895 comm="libvirtd" scontext=unconfined_u:system_r:virtd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tclass=tun_socket
mitmanek:~# 


Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-143.el6.noarch

How reproducible:
happened once and I don't know how to get rid of it

Steps to Reproduce:
1. see above, just start VM and try ping in it
2.
3.
  
Actual results:
ping stalls

Expected results:
normal network connection

Additional info:
from #selinux
11:11:45) mgrepl: mcepl: version of policy?
(11:12:04) mcepl: selinux-policy-3.7.19-143.el6.noarch
(11:15:03) mgrepl: mcepl: of course you have disabled unconfined
(11:15:07) mgrepl: open a new bug please
(11:15:11) mgrepl: I need to add it
(11:18:02) mcepl: mgrepl: can i quote this coversation in a bug?
(11:20:46) mgrepl: mcepl:sure
Comment 2 Daniel Walsh 2012-03-28 10:21:09 EDT
Fedora allows this.
Comment 6 errata-xmlrpc 2012-06-20 08:32:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0780.html

Note You need to log in before you can comment on or make changes to this bug.