This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 807592 - Need tuned profile packaging
Need tuned profile packaging
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: build (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anthony Towns
M S Vishwanath Bhat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 05:29 EDT by Vijay Bellur
Modified: 2016-05-31 21:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 01:11:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vijay Bellur 2012-03-28 05:29:23 EDT
Description of problem:

Performance engineering team has provided a set of tunables for RHS. 
The attached tuned files needs to be packaged for RHS.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ben England 2012-06-04 15:27:48 EDT
It appears to me that you packaged rhs-high-throughput profile correctly with the .iso .  Although you did not enable it by default, you did provide some additional default tuning in /etc/init.d/gluster-system-settings and you fixed max_sectors_kb by building /boot/initramfs*.img correctly.  We need a "low-latency" tuning profile as well but I'm not yet sure what should be in it.  Perhaps you can close this bug, and if a need for low-latency profile emerges we can re-open.  

Suggestion: you may want to take out comment about net.core.{r,w}mem_max from /etc/tune-profiles/rhs-high-throughput/sysctl.ktune since we no longer need it.
Comment 2 Anthony Towns 2012-06-18 04:53:46 EDT
Included since Apr 24 build of appliance-base
Comment 3 Sudhir D 2012-06-22 14:25:16 EDT
Verified by Ben England.

Note You need to log in before you can comment on or make changes to this bug.