Bug 807593 - Since kernel 3.3.0-4.fc16.i686 during boot and resume from hibernate there's a pause and message: ata2: link is slow to respond, please be patient
Since kernel 3.3.0-4.fc16.i686 during boot and resume from hibernate there's ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Patch, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 05:39 EDT by aaronsloman
Modified: 2012-04-09 14:34 EDT (History)
8 users (show)

See Also:
Fixed In Version: 3.3.1-3.fc16.i686
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 14:34:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aaronsloman 2012-03-28 05:39:39 EDT
Description of problem:
Since kernel 3.3.0-4.fc16.i686 I have found that during boot, and also when resuming from hibernate this message appears on screen (and also in /var/log/messages) with a pause of a couple of seconds before and after:
  ata2: link is slow to respond, please be patient (ready=0)

Version-Release number of selected component (if applicable):
Fedora 16 kernel 3.3.0-4 (fixed a bug that caused pm-hibernate to crash often).

How reproducible:
Happens always during boot, and most times during resume from hibernate.

Steps to Reproduce:
1. boot, or resume from pm-hibernate
(I use runlevel 3 - so do not enter graphical mode during booting and only at a very late stage during resume. People who start in graphical mode may not see this problem, unless they look in /var/log/messages. It will nevertheless add several seconds to time for boot/resume.)

2. Watch screen, just before resolution changes to high resolution.
3.
  
Actual results:
Typical entries before and after this in the messages file look like this:

Mar 22 21:44:23 lape kernel: [    2.820715] input: DualPoint Stick as /devices/platform/i8042/serio1/input/input5
Mar 22 21:44:23 lape kernel: [    2.834428] input: AlpsPS/2 ALPS DualPoint TouchPad as /devices/platform/i8042/serio1/input/input6
Mar 22 21:44:23 lape kernel: [    7.038582] ata2: link is slow to respond, please be patient (ready=0)
Mar 22 21:44:23 lape kernel: [   11.727992] ata2: COMRESET failed (errno=-16)
Mar 22 21:44:23 lape kernel: [   12.032830] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Mar 22 21:44:23 lape kernel: [   12.034832] ata2.00: ATAPI: MATSHITA DVD+/-RW UJ892, 1.05, max UDMA/100
Mar 22 21:44:23 lape kernel: [   12.037766] ata2.00: configured for UDMA/100
Mar 22 21:44:23 lape kernel: [   12.041771] scsi 1:0:0:0: CD-ROM            MATSHITA DVD+-RW UJ892    1.05 PQ: 0 ANSI: 5


Expected results:   Should not pause. Did not pause in earlier versions of f16 kernel.

Additional info:

This happens on Dell Latitude E6410 laptop:

Display:    WXGA+ Anti-Glare 1440x900 display (14" diagonal)
    Memory:     4GB (2x2048MB) 1066MHz DDR3 Dual Channel
    CPU:        Intel. CoreTM i5-540M (2.53GHz, 3M cache) with Turbo Boost Technology (four core)
    Graphics:   Intel: HD Graphics With Express Card
                Often referred to as Intel GMA 500 
                http://en.wikipedia.org/wiki/Intel_GMA#GMA_500        
    Hard Drive:      500GB SATA 7,200rpm hard drive,
         Seagate model:ST9500420AS 
    Media Bay:  8X DVD+/-RW Dri
    Wireless:   EMEA Intel Pro Wireless 6200 (802.11a/g/Draft-n 2X2) Mini Card
    Ethernet:   Intel Corporation 82577LM Gigabit Network Connection
    Webcam:     Integrated HD webcam with Microphone
    Internal UK/Irish Qwerty Backlit Keyboard
    Alps touch pad

I've used smartctl to test my hard drive and found no errors.

I can live with this, but thought I should report it in case it is a bug that should be fixed.

Google shows that "COMRESET failed (errno=-16)" is mentioned in several queries and bug reports in older versions of linux. I have checked my 'messages' files on the E6410 going back to January 2012 and find no sign of this before kernel 3.3.0-4.fc16.i686
Comment 1 Jaroslav Škarvada 2012-03-28 06:16:30 EDT
Does it work without pause in older kernels?
Comment 2 aaronsloman 2012-03-28 09:29:54 EDT
(In reply to comment #1)
> Does it work without pause in older kernels?

Yes. I had never seen this pause or error message before 3.3.0-4 (and I have been updating regularly in hope of finding hibernate fixed). E.g. it was definitely not there in the previous F16 3.3 kernel). So some change between immediately preceding version and 3.3.0-4 must have introduced this. If necessary I could go back to an earlier kernel and test.

I've not seen this at all on my desktop machine, also using intel core i5 and intel graphics, but running fedora 15.
Comment 3 aaronsloman 2012-03-28 17:17:29 EDT
This behaviour persists in the latest patch kernel .3.0-7.1.fc16.i686 #1 SMP Wed Mar 28 19:04:51 UTC 2012
Comment 4 aaronsloman 2012-03-28 17:38:29 EDT
(In reply to comment #3)
> This behaviour persists in the latest patch kernel .3.0-7.1.fc16.i686 #1 SMP
> Wed Mar 28 19:04:51 UTC 20

Correcting typo: that should have been
3.3.0-7.1.fc16.i686 #1 SMP Wed Mar 28 19:04:51 UTC 2012
Comment 5 Jaroslav Škarvada 2012-03-29 04:21:17 EDT
Thanks for reporting, it is kernel regression,
upstream ticket with link to patch:
https://bugzilla.kernel.org/show_bug.cgi?id=42733

Reassigning to kernel folks to review/apply the patch.
Comment 6 aaronsloman 2012-04-01 11:26:19 EDT
(In reply to comment #5)

> Reassigning to kernel folks to review/apply the patch.

Thanks for responding. Still present in the latest kernel installed by yum update: 3.3.0-8.fc16.i686
Comment 7 aaronsloman 2012-04-09 13:51:01 EDT
Seems to be fixed in 3.3.1-3.fc16.i686

Many thanks. Resume is now very fast.

I don't know how to change the bug status to "fixed"
Comment 8 Josh Boyer 2012-04-09 14:34:10 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.