Bug 807622 - Could not open modules.dep.temp for writing: No such file or directory
Could not open modules.dep.temp for writing: No such file or directory
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 07:00 EDT by Kamil Páral
Modified: 2013-07-04 09:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 08:26:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lorax log (77.61 KB, text/plain)
2012-03-28 07:00 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-03-28 07:00:29 EDT
Description of problem:
lorax fails for me every time. Last lines are:

WARNING: could not open /var/tmp/initramfs.jIUcEu/lib/modules/3.3.0-1.fc17.i686/modules.order: No such file or directory
WARNING: could not open /var/tmp/initramfs.jIUcEu/lib/modules/3.3.0-1.fc17.i686/modules.builtin: No such file or directory
WARNING: could not open /var/tmp/initramfs.55U93C/lib/modules/3.3.0-1.fc17.i686.PAE/modules.order: No such file or directory
WARNING: could not open /var/tmp/initramfs.55U93C/lib/modules/3.3.0-1.fc17.i686.PAE/modules.builtin: No such file or directory
WARNING: Couldn't open directory /tmp/lorax.PVRNQr/installtree/lib/modules/3.3.0-1.fc17.i686: No such file or directory
FATAL: Could not open /tmp/lorax.PVRNQr/installtree/lib/modules/3.3.0-1.fc17.i686/modules.dep.temp for writing: No such file or directory

See log.

Version-Release number of selected component (if applicable):
lorax-16.4.7-2.fc16.x86_64
lorax-16.4.8-2.fc16.x86_64

How reproducible:
always
Comment 1 Kamil Páral 2012-03-28 07:00:51 EDT
Created attachment 573305 [details]
lorax log
Comment 2 Kamil Páral 2012-03-29 04:41:38 EDT
It seems that the problem is caused by the fact that lorax is very old in Fedora 16. Fedora 17 contains a newer version which actually works. The questions is - why? Building F17 boot.iso on Fedora 16 is not a supported use case? I believe the tool should at least notify me in that case. And why don't you push the latest version to all supported releases?
Comment 3 Martin Gracik 2012-04-19 08:26:35 EDT
Lorax code always changes according to the needs of the next release that we need to compose. The tool is not really targeted for normal users, but for our release engineers, who use it in mock, so there's no point in pushing updates to older releases.

Note You need to log in before you can comment on or make changes to this bug.