Bug 807631 - Duplicated bracket types found error
Duplicated bracket types found error
Status: CLOSED NOTABUG
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 07:39 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 19:21:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-03-28 07:39:09 EDT
cspclient-0.22.5-1.noarch


[jwulf@nitai scratch]$ csprocessor create Test_Book_Template.contentspec 
CSProcessor client version: 0.22.5
Loading configuration from /home/jwulf/.config/csprocessor.ini
Connecting to Skynet server: http://skynet.usersys.redhat.com:8080/TopicIndex/

ERROR: Line 17: Duplicated bracket types found.
       -> This Book [N, Concept] [Content Spec Processor Tutorial Material]
ERROR: Line 17: Duplicated bracket types found.
       -> This Book [N, Concept] [Content Spec Processor Tutorial Material]
ERROR: The Content Specification is not valid.


Changing the line to:   

This Book [N, Concept, Content Spec Processor Tutorial Material]

works fine. Which is strange, because I've been using 

Title [N, {TopicType}] [{Tags}]

consistently with succcess. First time I've seen this error.
Comment 1 Lee Newson 2012-03-28 19:21:52 EDT
Well the second should always produce an error so that is the bug. It is invalid syntax and that shouldn't change. The syntax is supposed to be:

New topics:
<TITLE> [<ID>, <TYPE>, <TAGS>, <URLS>, <DESCRIPTION>] [RELATED TOPICS] [PREREQUISITE TOPICS] [TARGET]

Other Topics:
<TITLE> [<ID>, <TAGS>, <URLS>, <DESCRIPTION>] [RELATED TOPICS] [PREREQUISITE TOPICS] [TARGET]

So basically:

<Human Readable Title> <Topic Information> <Extra components about how the topic should be used in the CS>

As for the fact that you've been using "Title [N, {TopicType}] [{Tags}]" I can't find any records of it and cannot replicate it.

Note You need to log in before you can comment on or make changes to this bug.