Bug 807639 - References to "Frontend Realm" to be removed.
References to "Frontend Realm" to be removed.
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Angus Thomas
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 07:50 EDT by Aziza Karol
Modified: 2012-12-13 14:49 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 14:49:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ref to realm (200.03 KB, image/png)
2012-03-28 07:51 EDT, Aziza Karol
no flags Details
Realm names (247.73 KB, image/png)
2012-04-19 13:24 EDT, Angus Thomas
no flags Details
Realm Taken - no "frontend realm" mentioned (61.15 KB, image/png)
2012-09-21 17:08 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Aziza Karol 2012-03-28 07:50:25 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.create a cloud resource cluster  for ec2  and do  cluster mapping to ec2-us-east-1 and provider mapping to ec2-us-east-1: us-east-1a.
2.once the cloud resource cluster is created,click on Add mapping to cloud resource clusters and and again map to ec2-us-east-1.

  
Actual results:
"Frontend realm has already been taken" is displayed on UI.see attached screenshot.

Expected results:
Reference should be removed.

Additional info:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-conductor-doc-0.8.3-1.el6.noarch
aeolus-all-0.8.3-1.el6.noarch
aeolus-conductor-daemons-0.8.3-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-0.8.3-1.el6.noarch
Comment 1 Aziza Karol 2012-03-28 07:51:04 EDT
Created attachment 573317 [details]
ref to realm
Comment 2 Angus Thomas 2012-04-19 13:23:11 EDT
The correct names for front and back end realms in Cloud Engine are "Cloud Resource Cluster" and "Provider Realm"

In the attached screenshot, the button labelled "Add mapping to cloud resource cluster" should read "Add mapping to Provider Realm"

"Cloud Resource Cluster test is mapped to Provider Resource Cluster:" should read "Cloud Resource Cluster test is mapped to Provider Realm:"
Comment 3 Angus Thomas 2012-04-19 13:24:37 EDT
Created attachment 578711 [details]
Realm names
Comment 4 Scott Seago 2012-04-19 14:18:19 EDT
Angus -- are you pointing out additional UI issues to be fixed as part of this bug?

I'm seeing a few different things here, and I'm having trouble what exactly is the reported bug, what is expected use of the app, and what is being deliberately added to expose a bug:

1) In the error message "frontend realm" should read "cloud resource cluster" -- this looks like a valid translation/overrides problem.

2) For this step: " do  cluster mapping to ec2-us-east-1 and provider mapping to ec2-us-east-1: us-east-1a" -- are you only doing this to expose the duplication error? In practice it makes no sense to map to "ec2-us-east-1" _and_ to "ec2-us-east-1: us-east-1a". Mapping to "ec2-us-east-1" (i.e. a provider) says "match the provider as a whole; for this match we don't want to specify a provider realm, so leave that blank at launch". Mapping to "ec2-us-east-1: us-east-1a" says "match the ec2-us-east-1 provider and then, at launch, specify the provider realm "us-east-1a". In a real-world user situation, an admin would probably want to either map the provider (without realm) _or_ the provider realm -- the admin would _not_ want to map the provider (without realm) and, at the same time, map, separately, a realm for the _same_ provider.

3) Then, in step 2 you're making a third mapping -- to the same thing as the first mapping -- this is what triggers the 'name has been taken' error, since you're attempting to map the same provider twice.

4) Angus then points to another screenshot with two separate translation/overrides issues -- where we're using "Provider Resource Cluster" instead of "Provider Realm"

So, for the reported bug, I think the only actual bug reported is that we're using "Frontend Realm" instead of "Cloud Resource Cluster" -- although perhaps we should actually report a more obvious message to the effect that a provider (or provider realm) can only be mapped once to a Cloud Resource Cluster. Even better would be to, in addition, filter out the provider list to hide already-mapped providers and the realm list to hide already-mapped realms.
Comment 6 Ronelle Landy 2012-09-21 17:07:20 EDT
Tested rpms:

>> rpm -qa |grep aeolus
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch

Considering Comment 4 above ... verfied that "Frontend Realm" is no longer mentioned. remapping the same realm gives the following message:

**********

Errors

    1 error prohibited this Cloud Resource Provider Realm Backend Target from being saved
    Realm has already been taken

**********

See attached screenshot.
Comment 7 Ronelle Landy 2012-09-21 17:08:04 EDT
Created attachment 615634 [details]
Realm Taken - no "frontend realm" mentioned

Note You need to log in before you can comment on or make changes to this bug.