Bug 807641 - SELinux is preventing /usr/bin/nspluginviewer from using the 'signal' accesses on a process.
SELinux is preventing /usr/bin/nspluginviewer from using the 'signal' accesse...
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:fd8249d4edec1088e8080696d1a...
:
: 985544 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 07:52 EDT by Karel Volný
Modified: 2013-07-17 13:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-05 13:42:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2012-03-28 07:52:57 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-1.fc17.x86_64
reason:         SELinux is preventing /usr/bin/nspluginviewer from using the 'signal' accesses on a process.
time:           St 28. marec 2012, 13:52:06 CEST

description:
:SELinux is preventing /usr/bin/nspluginviewer from using the 'signal' accesses on a process.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that nspluginviewer should be allowed signal access on processes labeled unconfined_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep nspluginviewer /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0
:Target Context                unconfined_u:unconfined_r:unconfined_t:s0
:Target Objects                 [ process ]
:Source                        nspluginviewer
:Source Path                   /usr/bin/nspluginviewer
:Port                          <Neznáme>
:Host                          (removed)
:Source RPM Packages           kde-baseapps-4.8.1-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-106.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-1.fc17.x86_64 #1 SMP Mon Mar
:                              19 03:03:39 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    St 28. marec 2012, 13:50:22 CEST
:Last Seen                     St 28. marec 2012, 13:50:22 CEST
:Local ID                      33cc5a76-6ef5-45a4-adf5-2cdd29a2c4a2
:
:Raw Audit Messages
:type=AVC msg=audit(1332935422.390:284): avc:  denied  { signal } for  pid=13248 comm="nspluginviewer" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0 tcontext=unconfined_u:unconfined_r:unconfined_t:s0 tclass=process
:
:
:type=SYSCALL msg=audit(1332935422.390:284): arch=x86_64 syscall=kill success=no exit=EACCES a0=33c1 a1=f a2=1b0b2f0 a3=7a2e4b items=0 ppid=13224 pid=13248 auid=1000 uid=1000 gid=1002 euid=1000 suid=1000 fsuid=1000 egid=1002 sgid=1002 fsgid=1002 tty=(none) ses=1 comm=nspluginviewer exe=/usr/bin/nspluginviewer subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0 key=(null)
:
:Hash: nspluginviewer,mozilla_plugin_t,unconfined_t,process,signal
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-03-28 09:21:01 EDT
Karel,
how did you get this one?
Comment 2 Daniel Walsh 2012-03-28 10:22:41 EDT
Not something we want to allow, a confined plugin killing user processes.
Comment 3 Karel Volný 2012-03-29 10:57:24 EDT
(In reply to comment #1)
> Karel,
> how did you get this one?

fresh install of Fedora 17 Alpha

I've tried to watch a video on youtube in Konqueror

I don't remember exactly, but I think this was with KHTML and gnash-klash (I've tried various combinations until I've found that WebKit + gnash-plugin is the one that works)

(In reply to comment #2)
> Not something we want to allow, a confined plugin killing user processes.

I don't understand the messages exactly, but what I believe that happened is that nspluginviewer tried to kill the plugin it was running

which I'd say is perfectly legal for it - it acts as a wrapper and it should be able to shot down any misbehaving process under its control

so I see it as a problem how to determine whether it tries to kill the right process to allow that and disallow touching others
Comment 4 Daniel Walsh 2012-03-29 13:21:55 EDT
Well the AVC's indicate the reverse. The plugin mozilla_plugin_t is sending a kill signal to an unconfined_t.
Comment 5 Daniel Walsh 2012-03-29 13:24:01 EDT
Did everything seem to work, other then the AVC was generated?  I have a fealing we are running a part of the process under unconfined_t that should probably be running under npviewer/mozilla_plugin_t and then the signal would have been allowed.
Comment 6 Karel Volný 2012-03-30 11:14:08 EDT
(In reply to comment #5)
> Did everything seem to work, other then the AVC was generated?

no, the video did not play

I was playing with various combinations of Konqueror KHTML/WebKit - gnash-klahs/gnash-plugin today too, and I haven't seen such messages any more
- however, now it seems that YT uses HTML5 instead of Flash for playback in Konqueror ... so I guess I'll need to find another reproducer site (it hasn't happened on Adobe's about Flash web page)
Comment 7 Miroslav Grepl 2012-10-17 05:05:30 EDT
Are you still getting this?
Comment 8 Karel Volný 2012-11-02 13:31:50 EDT
(In reply to comment #7)
> Are you still getting this?

no, because I'm using Adobe's Flash instead of Gnash/Klash :)

as I'm a bit tired by the Gnash development (or better say, lack of), I don't have any interest in investigating this further

feel free to close this or just try to reproduce yourself

sorry for the bugzilla noise, half a year ago I was a bit more optimistic about getting this to work

(and sorry guys for using this piece of sh...software with such a long list of security issues, but it just works, and as long as we have to use sites like instructor.cz, I can hardly live without Flash support ...)
Comment 9 Rex Dieter 2013-07-17 13:44:39 EDT
*** Bug 985544 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.