Bug 807649 - Build kdump image fails when kdump.conf has net option with a host name not a ip address.
Build kdump image fails when kdump.conf has net option with a host name not a...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Young
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 807651
  Show dependency treegraph
 
Reported: 2012-03-28 08:08 EDT by WANG Chao
Modified: 2013-01-30 02:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 807651 (view as bug list)
Environment:
Last Closed: 2013-01-30 02:11:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description WANG Chao 2012-03-28 08:08:03 EDT
Description of problem:
Add 'net root@my.server.com' to /etc/kdump.conf
run `kdumpctl propagate`, pass.
run `kdumpctl restart`:
Stopping kdump:
Detected /etc/kdump.conf or /boot/vmlinuz-3.2.1-0.9.el7.x86_64 change
Rebuilding /boot/initramfs-3.2.1-0.9.el7.x86_64kdump.img
rpmversion
network
ifcfg
dm
kernel-modules
lvm
fstab-sys
rootfs-block
ssh-client
udev-rules
base
fs-lib
kdumpbase
Bad kdump location: root@my.server.com
Failed to run mkdumprd
Starting kdump:

After a dig, I find 99kdumpbase/module-setup.sh line 60:
_netdev=`/sbin/ip route get to $_server 2>&1`

When $_server is a host name not an ip address, command ip will fail with 'Error: an inet prefix is expected rather than my.server.com', because command ip always only deals with ip address.

Version-Release number of selected component (if applicable):
kexec-tools-2.0.3-41.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
Mentioned above.
  
Actual results:
Build kdump image fails.

Expected results:
Build kdump image successes.

Additional info:
Comment 1 Fedora Update System 2012-03-29 23:55:48 EDT
kexec-tools-2.0.3-42.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kexec-tools-2.0.3-42.fc17
Comment 2 Fedora Update System 2012-03-30 13:58:55 EDT
Package kexec-tools-2.0.3-42.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kexec-tools-2.0.3-42.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4916/kexec-tools-2.0.3-42.fc17
then log in and leave karma (feedback).
Comment 3 WANG Chao 2012-04-11 05:15:41 EDT
Hi, Dave,

I failQA this bug, so you can revert your commit or you can also commit another patch to fix it.

-Chao
Comment 4 Fedora Update System 2012-04-11 07:44:29 EDT
kexec-tools-2.0.3-43.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kexec-tools-2.0.3-43.fc17
Comment 5 Fedora Update System 2012-04-11 21:10:11 EDT
Package kexec-tools-2.0.3-43.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kexec-tools-2.0.3-43.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5715/kexec-tools-2.0.3-43.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Admin XMLRPC Client 2012-04-16 02:13:11 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 joshua 2013-01-28 15:49:19 EST
Is this fixed and now in the regular non-testing repos?
Comment 8 Dave Young 2013-01-28 21:04:03 EST
Yep, latest f17 stable rpm is kexec-tools-2.0.3-47.fc17.4
Comment 9 joshua 2013-01-30 01:34:44 EST
Excellent... so can we close this out?
Comment 10 Dave Young 2013-01-30 02:11:10 EST
Ok, closing...

Note You need to log in before you can comment on or make changes to this bug.