Bug 807714 - v7 1.5 R12 requires udisks package not in RHEL5
v7 1.5 R12 requires udisks package not in RHEL5
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Petr Beňas
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-03-28 10:39 EDT by Greg Nichols
Modified: 2015-01-04 18:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hardwaretest patch to pass product information into device planning (960 bytes, patch)
2012-04-02 15:45 EDT, Greg Nichols
no flags Details | Diff
planner patch to only use udisks on RHEL 6 and beyond, and all other products (1.31 KB, patch)
2012-04-02 15:46 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2012-03-28 10:39:41 EDT
Description of problem:

v7 1.5 introduces udisks as a HAL replacement.   There is no udisks package in RHEL5

Version-Release number of selected component (if applicable):

v7 1.5
Comment 1 Greg Nichols 2012-03-28 10:42:37 EDT
If installed ignoring dependancies on udisks, the follow traceback occurs:

[root@dell-pe1950-02 ~]# v7 plan --server gnichols.usersys.redhat.com
found interface for udisks
Introspect error: The name org.freedesktop.UDisks was not provided by any .service files
Traceback (most recent call last):
  File "/usr/bin/v7", line 45, in ?
    success = v7.do(args)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 194, in do
    result = self.commands[self.command]()
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 323, in doPlan
    tests = self.planner.plan() 
  File "/usr/share/v7/lib/v7/planner.py", line 114, in plan
    self.__loadDevices()
  File "/usr/share/v7/lib/v7/planner.py", line 129, in __loadDevices
    self.devices.extend(udisks.getDevices())
  File "/usr/share/v7/lib/v7/udisksDeviceDetector.py", line 49, in getDevices
    for devicePath in self.interface.EnumerateDevices():
  File "/usr/lib64/python2.4/site-packages/dbus/proxies.py", line 25, in __call__
    ret = self._proxy_method (*args, **keywords)
  File "/usr/lib64/python2.4/site-packages/dbus/proxies.py", line 102, in __call__
    reply_message = self._connection.send_with_reply_and_block(message, timeout)
  File "dbus_bindings.pyx", line 455, in dbus_bindings.Connection.send_with_reply_and_block
dbus_bindings.DBusException: The name org.freedesktop.UDisks was not provided by any .service files
Comment 5 Petr Beňas 2012-04-02 05:13:15 EDT
Reproduced in v7-1.5-12.el5.noarch and verified in v7-1.5-13.el5.noarch.
Comment 6 Rob Landry 2012-04-02 11:14:29 EDT
Could the code be updated to not list out the introspect error?  It seems like maybe the udisk detection is returning true and then failing.
Comment 11 Greg Nichols 2012-04-02 15:45:01 EDT
Created attachment 574608 [details]
hardwaretest patch to pass product information into device planning
Comment 12 Greg Nichols 2012-04-02 15:46:26 EDT
Created attachment 574609 [details]
planner patch to only use udisks on RHEL 6 and beyond, and all other products
Comment 15 Petr Beňas 2012-04-03 04:26:25 EDT
Additional fixes verified in R14.
Comment 16 Caspar Zhang 2012-06-04 03:59:40 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 18 errata-xmlrpc 2012-06-05 17:37:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.