Bug 807782 - instant reproducable X crash
instant reproducable X crash
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 13:19 EDT by Máirín Duffy
Modified: 2012-03-28 13:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 13:53:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log.old (41.91 KB, application/octet-stream)
2012-03-28 13:20 EDT, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2012-03-28 13:19:31 EDT
Description of problem:

Don't laugh but... I installed supertuxkart-0.7-2.fc15.x86_64 and went to options, and tried to change the resolution to be the highest available for my machine. When I hit 'apply new resolution', the screen went black, I got the GNOME spinner icon, and then a GDM login screen. 

This happened on a Lenovo X220 Tablet as well as a Lenovo T500 system.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.11.1-1.fc16.x86_64

If I type export LIBGL_ALWAYS_SOFTWARE=Y in a gnome-terminal then run supertuxkart from that terminal, this issue goes away. 

How reproducible:

Very

Steps to Reproduce:
1. run supertuxkart
2. go to options menu
3. change resolution to be higher than 800x600
4. hit apply
  
Actual results:

5. X go boom

Expected results:

5. Having an awesome game of Super Tux Kart

Additional info:

I am attaching the Xorg.0.log.old so you can see the backtrace.

Thanks for looking into this bug, I really appreciate it!
Comment 1 Máirín Duffy 2012-03-28 13:20:41 EDT
Created attachment 573404 [details]
Xorg.0.log.old
Comment 2 Adam Jackson 2012-03-28 13:27:58 EDT
[  1204.142] Build ID: xorg-x11-server 1.11.1-1.fc16
...
[  1204.294] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[  1204.294] (II) Module intel: vendor="X.Org Foundation"
[  1204.294] 	compiled for 1.10.99.902, module version = 2.16.0

That's fairly old, newest xserver in f16-updates is 1.11.4-2.fc16, and xorg-x11-drv-intel 2.17.0-8.fc16.  Do you still experience this with current updates installed?
Comment 3 Máirín Duffy 2012-03-28 13:53:52 EDT
Phew, it is fixed in the latest, thank you so much!!!!!!

(I did have a newer one on the x220, the version above is on the T500, but there was a new update and that seems to take care of the issues)

Note You need to log in before you can comment on or make changes to this bug.