Bug 807863 - RFE: Automatically tag/untag topics with Spec.<Spec ID> tag
RFE: Automatically tag/untag topics with Spec.<Spec ID> tag
Status: CLOSED DUPLICATE of bug 831910
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 20:12 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-26 01:20:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-03-28 20:12:36 EDT
At the moment I tag the topics in my content spec with the "name of the book". 

This allows me to locate the topics in the content spec with a Skynet filter.

What would be useful is this:

A category called "Spec Inclusion", which has tags that correspond to SPEC IDs.

When a content spec is pushed to the server, if a tag does not exist for that Spec, then one is created. All topics in that spec have the tag for that spec applied. 

If topics are removed from a spec (this would probably require comparison with the last version of the spec), then the tag for that spec is removed from the topic.

This would allow me to look at any topic in the repository and tell which specs it is included in. This would be extremely useful in a number of cases:

*  When editing a topic, it is important to see what all the consequences of the edit will be
*  When a critical flaw is identified in one book, all books that contain that flaw (that topic) can be quickly identified and rebuilt

It would also allow me to reliably filter topics based on a content spec.
Comment 1 Lee Newson 2012-03-28 20:21:18 EDT
You are aware that there is a Search Feature that will list all of the topics in a content specification right? Have a look at the Search->Fields->Is Included In Content Spec attribute. (Note: it can only take one content specification)

As for the rest of it I'll look later and comment then.
Comment 2 Joshua Wulf 2012-03-28 20:29:32 EDT
Nope, didn't know that! Thanks, I'll add it to the guide.

So that covers finding "all topics in Spec X"

The other consequence of this RFE is the ability to look at a given topic and say with certainty: 

"This topic is in Specs X, Y, and Z"
Comment 3 Lee Newson 2013-04-26 01:20:11 EDT
Marking this as a duplicate of #831910 even though this was technically first, only because #831910 is the bug we've been linking to.

*** This bug has been marked as a duplicate of bug 831910 ***

Note You need to log in before you can comment on or make changes to this bug.