Bug 807878 - Cannot hear sound when passthrough a USB speaker into RHEL guest
Cannot hear sound when passthrough a USB speaker into RHEL guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
: 807250 (view as bug list)
Depends On:
Blocks: 808653
  Show dependency treegraph
 
Reported: 2012-03-28 22:24 EDT by Qingtang Zhou
Modified: 2013-01-09 19:49 EST (History)
11 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.276.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
: 808653 (view as bug list)
Environment:
Last Closed: 2012-06-20 07:45:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsusb output for USB speaker in host/guest (11.61 KB, application/octet-stream)
2012-03-28 22:24 EDT, Qingtang Zhou
no flags Details

  None (edit)
Description Qingtang Zhou 2012-03-28 22:24:30 EDT
Created attachment 573500 [details]
lsusb output for USB speaker in host/guest

Description of problem:
I passthrough a USB speaker into RHEL6 guest, this device can be recognized by guest.
But I can't hear any sound from this speaker when playing an audio file. And qemu
reports "invalid descriptor data".

`lsusb -vvv` output in host/guest is attached.

Version-Release number of selected component (if applicable):
Tested on host
# rpm -q kernel
kernel-2.6.32-257.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.266.el6.x86_64

with guest
# rpm -q kernel
kernel-2.6.32-188.el6.i686


How reproducible:
100%

Steps to Reproduce:
1. Start a RHEL6 guest with USB speaker passthroughed.
2. Choose "USB speaker" in "Sound Perferences" of guest.
3. Play a audio
4. Can't hear any sound.
  
Actual results:
This speaker can be found in guest, and the "Sound Perferences" in gnome can find this speaker, but cant hear sound from it.

qemu stderr output:
-------------------
husb: open device 6.2
husb: grabbed usb device 6.2
QEMU 0.12.1 monitor - type 'help' for more information
(qemu) husb: config #1 need 1
husb: 3 interfaces claimed for configuration 1
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data

Expected results:


Additional info:
qemu-kvm cli:
-------------
# /home/autotest-devel/client/tests/kvm/qemu \
-name 'vm1' \
-chardev socket,id=qmp_monitor_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20120307-165504-TPw7,server,nowait \
-mon chardev=qmp_monitor_id_qmpmonitor1,mode=control \
-chardev socket,id=serial_id_20120307-165504-TPw7,path=/tmp/serial-20120307-165504-TPw7,server,nowait \
-device isa-serial,chardev=serial_id_20120307-165504-TPw7 \
-device ich9-usb-uhci1,id=usb1,bus=pci.0 \
-drive file='/home/autotest-devel/client/tests/kvm/images/RHEL-Server-6.2-32-virtio.qcow2',if=none,id=drive-virtio-disk1,media=disk,cache=none,boot=on,format=qcow2,aio=native \
-device virtio-blk-pci,bus=pci.0,addr=0x9,drive=drive-virtio-disk1,id=virtio-disk1 \
-m 4096 \
-smp 2,cores=1,threads=1,sockets=2 \
-cpu cpu64-rhel6,+sse2,+x2apic \
-rtc base=utc,clock=host,driftfix=slew \
-M rhel6.3.0 \
-boot order=cdn,once=c,menu=off    \
-no-kvm-pit-reinjection \
-enable-kvm \
-monitor stdio \
-device usb-host,hostbus=6,hostaddr=2,bus=usb1.0,id=spk \
-device usb-tablet  \
-device virtio-net-pci,netdev=net0,id=virtionet0,mac=00:11:22:33:44:66,bus=pci.0 \
-netdev tap,id=net0,vhost=on,fd=21 \
-vnc :1
(or -spice port=8000,disable-ticketing" for spice mode.)


host dmesg:
-----------
usb 6-1: reset full speed USB device number 2 using uhci_hcd
input: USB Speaker as /devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1:1.2/input/input10
generic-usb 0003:0C76:160C.0004: input,hidraw0: USB HID v1.00 Device [USB Speaker] on usb-0000:00:1d.0-1/input2
usb 6-1: reset full speed USB device number 2 using uhci_hcd
usb 6-1: reset full speed USB device number 2 using uhci_hcd
usb 6-1: reset full speed USB device number 2 using uhci_hcd
usb 6-1: reset full speed USB device number 2 using uhci_hcd
usb 6-1: reset full speed USB device number 2 using uhci_hcd
usb 6-1: reset full speed USB device number 2 using uhci_hcd
usb 6-1: reset full speed USB device number 2 using uhci_hcd
usb 6-1: usbfs: interface 0 claimed by snd-usb-audio while 'qemu' sets config #1

guest dmesg:
------------
# dmesg |grep -i usb
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
uhci_hcd: USB Universal Host Controller Interface driver
uhci_hcd 0000:00:03.0: new USB bus registered, assigned bus number 1
usb usb1: New USB device found, idVendor=1d6b, idProduct=0001
usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb1: Product: UHCI Host Controller
usb usb1: Manufacturer: Linux 2.6.32-188.el6.i686 uhci_hcd
usb usb1: SerialNumber: 0000:00:03.0
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
usbcore: registered new interface driver hiddev
usbcore: registered new interface driver usbhid
usbhid: v2.6:USB HID core driver
usb 1-1: new full speed USB device using uhci_hcd and address 2
usb 1-1: New USB device found, idVendor=0c76, idProduct=160c
usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
usb 1-1: Product: USB Speaker
usb 1-1: configuration #1 chosen from 1 choice
input: USB Speaker as /devices/pci0000:00/0000:00:03.0/usb1/1-1/1-1:1.2/input/input4
generic-usb 0003:0C76:160C.0001: input,hidraw0: USB HID v1.00 Device [USB Speaker] on usb-0000:00:03.0-1/input2
usb 1-2: new full speed USB device using uhci_hcd and address 3
usb 1-2: New USB device found, idVendor=0000, idProduct=0000
usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-2: Product: QEMU USB Hub
usb 1-2: Manufacturer: QEMU 0.12.1
usb 1-2: SerialNumber: 314159
usb 1-2: configuration #1 chosen from 1 choice
hub 1-2:1.0: USB hub found
usb 1-2.1: new full speed USB device using uhci_hcd and address 4
usb 1-2.1: New USB device found, idVendor=0627, idProduct=0001
usb 1-2.1: New USB device strings: Mfr=1, Product=3, SerialNumber=5
usb 1-2.1: Product: QEMU USB Tablet
usb 1-2.1: Manufacturer: QEMU 0.12.1
usb 1-2.1: SerialNumber: 42
usb 1-2.1: configuration #1 chosen from 1 choice
input: QEMU 0.12.1 QEMU USB Tablet as /devices/pci0000:00/0000:00:03.0/usb1/1-2/1-2.1/1-2.1:1.0/input/input5
generic-usb 0003:0627:0001.0002: input,hidraw1: USB HID v0.01 Pointer [QEMU 0.12.1 QEMU USB Tablet] on usb-0000:00:03.0-2.1/input0
usbcore: registered new interface driver snd-usb-audio
Comment 2 Gerd Hoffmann 2012-03-29 03:50:07 EDT
Probably a qemu-kvm bug, the "invalid descriptor data" messages hint that.
There is bug 807250, same issue for windows guest, could be the same root cause.
Comment 6 Gerd Hoffmann 2012-03-30 04:58:01 EDT
*** Bug 807250 has been marked as a duplicate of this bug. ***
Comment 13 langfang 2012-04-18 02:59:23 EDT
reporduce this issue with steps and  environment as follows:
host:
#uname -r 
2.6.32-262.el6.x86_64
#rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.272.el6.x86_64
guest:
2.6.32-272.el6.x86_64

Steps to Reproduce:
1. Start a RHEL6 guest with USB speaker passthroughed.
2. Choose "USB speaker" in "Sound Perferences" of guest.
3. Play a audio
4. Can't hear any sound.

my CLI:/usr/libexec/qemu-kvm -m 2G -smp 2 -cpu Penryn,+x2apic, -usbdevice tablet -drive file=/home/rhel6.3-64.qcow2,format=qcow2,if=none,id=drive-virtio-disk0,werror=stop,rerror=stop,cache=none -device virtio-blk-pci,drive=drive-virtio-disk0,id=ide0-0-0,bootindex=1 -uuid bc898f4c-93e8-48d7-b1f6-05eb4c611129 -rtc base=utc,clock=host,driftfix=slew -no-kvm-pit-reinjection -monitor stdio -name rhel5.7 -spice port=5830,disable-ticketing -vga qxl -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup,downscript=no -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,bootindex=2 -usb -device usb-host,hostbus=3,hostaddr=6,id=hostdev1

results:

invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data
invalid descriptor data

verify this issue
#uname -r 
2.6.32-262.el6.x86_64
#rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.272.el6.x86_64
guest:
2.6.32-277.el6.x86_64

(the step as same as the reproduce)
results: can be hear the video sound,the output
husb: out of buffers for iso stream
husb: out of buffers for iso stream
husb: out of buffers for iso stream
husb: out of buffers for iso stream
husb: out of buffers for iso stream
husb: out of buffers for iso stream
husb: out of buffers for iso stream
husb: out of buffers for iso stream
husb: out of buffers for iso stream
husb: out of buffers for iso stream


the video sound can be hear,so this issue has been fixed~~~
Comment 14 Dor Laor 2012-04-22 07:31:41 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed
Comment 16 errata-xmlrpc 2012-06-20 07:45:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0746.html

Note You need to log in before you can comment on or make changes to this bug.