Bug 807889 - php-embedded is not providing libphp5-5.4.0.so
php-embedded is not providing libphp5-5.4.0.so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 00:02 EDT by Bruno Wolff III
Modified: 2012-03-30 07:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 07:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2012-03-29 00:02:54 EDT
Description of problem:
maniadrive will not install in rawhide, because although php-embedded-5.4.0-3.fc18.i686 includes /usr/lib/libphp5-5.4.0.so, it doesn't actually provide libphp5-5.4.0.so.
It's possible this might have something to do with the new version of rpm, but it's hard for me to tell.
This is on an i686 machine. It's possible that x86_64 is different.
Comment 1 Remi Collet 2012-03-29 01:21:30 EDT
Arg... I see : the filter to avoid providing private .so is to wide

I will this fix asap.
Comment 2 Bruno Wolff III 2012-03-29 08:49:13 EDT
It looks like this message about an rpm issue could potentially apply here:
http://lists.fedoraproject.org/pipermail/devel/2012-March/165064.html
Comment 3 Remi Collet 2012-03-29 09:35:55 EDT
@Bruno : you're right.
Last build was March 26 (so, with the broken rpm) and filters are fine (only exclude /usr/lib*/php*/modules/*)

So, a simple rebuild should be fine.

As I'm AFK, I couldn't launch this now, but will this week-end (except if somebody could launch it before)
Comment 4 Joe Orton 2012-03-30 07:26:02 EDT
Done.

php-embedded-devel = 5.4.0-4.fc18
php-embedded-devel(x86-64) = 5.4.0-4.fc18
php-embedded = 5.4.0-4.fc18
php-embedded(x86-64) = 5.4.0-4.fc18
libphp5-5.4.0.so()(64bit)

Note You need to log in before you can comment on or make changes to this bug.