Bug 807921 - migration got failed for jenkins type app
migration got failed for jenkins type app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
1.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
: 807918 (view as bug list)
Depends On:
Blocks: 808229
  Show dependency treegraph
 
Reported: 2012-03-29 03:15 EDT by Meng Bo
Modified: 2013-11-17 19:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-03-29 03:15:42 EDT
Description of problem:
create jenkins server and embed jenkins client to exist app. do upgrade and migration, jenkins app will get failed during migration.

Version-Release number of selected component (if applicable):
devenv_1679
migrate-mongo-2.0.8
migrate-2.0.8

How reproducible:
always

Steps to Reproduce:
1.start old instance devenv-stage_150
2.create jenkins app and embed jenkins-client to other apps
3.do upgrade and migration
migrate-mongo-2.0.8
migrate-2.0.8

  
Actual results:
will get Node execution failure for jenkins apps

Expected results:
migration should not get any problems.

Additional info:

Failed to migrate with cmd: './migrate-2.0.8 --rhlogin 'bmeng+2@redhat.com' --migrate-app 'jenkins'' after 2 tries with exception: Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.
/var/www/stickshift/broker/lib/express/broker/application_container_proxy.rb:890:in `run_cartridge_command'/var/www/stickshift/broker/lib/express/broker/application_container_proxy.rb:293:in `status'./migrate-2.0.8:77:in `restart_app'./migrate-2.0.8:52:in `migrate_app'/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:258:in `call'/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:258:in `custom_request'/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:511:in `call'/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:511:in `process_results_with_block'/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:450:in `call_agent'/usr/lib/ruby/site_ruby/1.8/mcollective/client.rb:129:in `req'/usr/lib/ruby/site_ruby/1.8/mcollective/client.rb:124:in `loop'/usr/lib/ruby/site_ruby/1.8/mcollective/client.rb:124:in `req'/usr/lib/ruby/1.8/timeout.rb:67:in `timeout'/usr/lib/ruby/site_ruby/1.8/mcollective/client.rb:123:in `req'/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:446:in `call_agent'/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:257:in `custom_request'/usr/lib/ruby/site_ruby/1.8/mcollective/rpc/client.rb:193:in `method_missing'./migrate-2.0.8:34:in `migrate_app'/var/www/stickshift/broker/lib/express/broker/application_container_proxy.rb:611:in `rpc_exec'./migrate-2.0.8:33:in `migrate_app'/usr/lib/ruby/1.8/timeout.rb:67:in `timeout'./migrate-2.0.8:32:in `migrate_app'./migrate-2.0.8:386:in `migrate_from_file'./migrate-2.0.8:384:in `each'./migrate-2.0.8:384:in `migrate_from_file'./migrate-2.0.8:496
Output:
Migrating app on node with: ./migrate-2.0.8 --rhlogin 'bmeng+2@redhat.com' --migrate-app 'jenkins'
Comment 1 Rob Millner 2012-03-29 21:24:45 EDT
Fixed in commit 07f359c0.
Comment 2 Rob Millner 2012-03-29 21:40:51 EDT
*** Bug 807918 has been marked as a duplicate of this bug. ***
Comment 3 Meng Bo 2012-03-29 22:50:12 EDT
verified with latest migrate-mongo-2.0.8 and migrate-2.0.8,
issue has been fixed.

Note You need to log in before you can comment on or make changes to this bug.