Bug 807924 - rhel5.8 32/64 bit citrix guest's device.map do not be updated after conversion using p2v
rhel5.8 32/64 bit citrix guest's device.map do not be updated after conversio...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 03:24 EDT by tingting zheng
Modified: 2015-03-12 13:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-12 13:40:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2012-03-29 03:24:56 EDT
Description of Problem:
When using virt-p2v to convert a rhel5.8 32/64 bit citrix guest's to libvirt and rhevm,device.map do not be updated after conversion using p2v

Version-Release number of selected component:
virt-v2v-0.8.7-4.el6.x86_64
rubygem-virt-p2v-0.8.6-2.el6


How reproducible:
Always

Step to Reproduce:
1.Download the virt-p2v iso from brewweb.

2.Install rhel5.8 guest on citrix.

3.Boot the guest with virt-p2v from pxe,input the ip and password of conversion server,convert it to libvirt and rhevm.

4.After conversion,check the device.map of the guest.
# cat /boot/grub/device.map
# this device map was generated by anaconda
(hd0)     /dev/hda

5.Check the disk of the guest.
#fdisk -l
...
Disk /dev/vda: 16.1 GB, 16106127360 bytes
...


Actual Results:
The device map do not be updated after conversion using p2v


Expected Results:
The device map should be updated to vda.

Additional info:
Comment 2 RHEL Product and Program Management 2012-05-03 00:37:23 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Richard W.M. Jones 2015-03-12 13:40:35 EDT
I'm closing this bug:

 - virt-p2v has been rewritten for RHEL 7.2

 - Unofficial previews of the new version are available:
   http://oirase.annexia.org/virt-p2v/

 - If a similar bug occurs with the new version of virt-p2v,
   please open a new bug against Red Hat Enterprise Linux 7 / libguestfs

Note You need to log in before you can comment on or make changes to this bug.