Bug 80794 - selecting the finnish-latin1 keyboard in kbdvonfig 1.9.16 causes an extra " to appear when pressing the alt gr button
selecting the finnish-latin1 keyboard in kbdvonfig 1.9.16 causes an extra " t...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-31 09:57 EST by Jan Westin
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 17:27:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Westin 2002-12-31 09:57:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When the fi-latin1 keyboard configuration is selected problems occur when I try
to type in a symbol acsessed from a alt gr keyboard combination. For example
when typing an @ letter a ” appear in front of the @, like this ”@. Pressing the
alt gr button alone results in a ” being written on screan.
The problem is system wide, and is frusturating in everyday work, and especially
when you can't use the backspace key to delete the extra symbol.
One thing that I have noticed is that depending on the program the extra symbol
changes.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.log in as root 
2.acsess the setup & set the keyboard to fi-latin1
3.try and type a @ anywhere 
    

Actual Results:  extra symbols appear when pressing alt gr button on keyboard

Expected Results:  eg.
A simple @ would be nice instead of ”@

Additional info:

One workaruond that I have found by misstake is, that this problem disappears in
KDE when deselecting Keyboard repeat in Controlpanel -> Peripherals -> Keyboard
I am not sure if this fixes it system wide, but at least in KDE applications.
Comment 1 Brent Fox 2003-02-07 00:09:56 EST
I think that redhat-config-keyboard is loading the correct console keymap
(fi-latin1).  It seems that the bug is in the keymap itself.  I'm changing the
component of this report to kbd.
Comment 2 Sepp Rudel 2003-04-14 02:55:21 EDT
FWIW,

I *think* I saw this same problem also with Danish keyboard, but after that I
tweaked config files by hand and now I can't reproduce it. However, if there
would be a problem with @ in Danish or Finnish keymaps, wouldn't there be bug
reports flying all around, since @ is so much needed nowadays? My guess is that
this is either a redhat-config-keyboard problem or a local configuration hickup.
Comment 3 Eido Inoue 2003-08-01 17:27:28 EDT
can't reproduce with a stock 8. Additionally, please try the kbd in rawhide
which has a new fi.map (which is no longer 7-bit) but the same fi-latin1.map.

Note You need to log in before you can comment on or make changes to this bug.