Bug 807941 - Guest file was not removed when reboot or shut down in p2v conversion
Guest file was not removed when reboot or shut down in p2v conversion
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 03:58 EDT by Cui Lei
Modified: 2015-03-12 13:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-12 12:59:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cui Lei 2012-03-29 03:58:28 EDT
Description of problem:
When use virt-p2v convert a source machine to a virtual guest, shut down or reboot the machine to interrupt the conversion, virt-p2v would not remove the incomplete guest domain file.
The incomplete file should be removed or the disk space would be wasted in p2v server.

Version-Release number of selected component (if applicable):
always

How reproducible:


Steps to Reproduce:
1.Download the virt-p2v iso from brewweb.

2.Boot the guest with virt-p2v from pxe,input the ip and password of conversion server,convert it to libvirt.

3.In the process of conversion(do not finish), reboot or shut down the source machine or guest to interrupt the conversion.

4.Go to P2V server, check if the incomplete guest domain file was exist
  
Actual results:
The incomplete guest domain file was exist

Expected results:
The incomplete guest domain file should be removed

Additional info:
Comment 2 Cui Lei 2012-03-29 04:29:33 EDT
Update the Version-Release number

Version-Release number of selected component (if applicable):
virt-v2v-0.8.7-4.el6.x86_64
virt-p2v-0.8.6-2
libvirt-0.9.10-7.el6.x86_64
kernel-2.6.32-251.el6
 
How reproducible:
Always
Comment 3 Cui Lei 2012-04-18 01:47:15 EDT
Add two new scenario:
1. "No root device in this operating system image"
2. "Do not support multiple boot OS..."
These two scenario could be check out by virt-p2v, but the roll back action(delete target guest file) do not execute.
If DEV think these two scenario would fixed by another way different from the original issue, I could submitted another bug.
Comment 4 RHEL Product and Program Management 2012-05-03 00:49:02 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 6 Richard W.M. Jones 2015-03-12 12:59:47 EDT
Closing UPSTREAM because virt-v2v (the server side of virt-p2v)
now cleans up at least the disk images in the event of any type
of failure.

Note You need to log in before you can comment on or make changes to this bug.