Bug 807950 - Virt-p2v should provide a cancel button in convert page
Virt-p2v should provide a cancel button in convert page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 04:24 EDT by Cui Lei
Modified: 2015-03-12 13:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-12 13:36:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cui Lei 2012-03-29 04:24:18 EDT
Description of problem:
It is a friendly issue. It is not convenient for customer can not interrupt conversion as there is no cancel button. As usually p2v conversion takes a long time, customer may want to change some settings in the conversion. Currently customer could only reboot or shut down the source machine to interrupt the conversion.

Version-Release number of selected component (if applicable):
virt-v2v-0.8.7-4.el6.x86_64
virt-p2v-0.8.6-2
libvirt-0.9.10-7.el6.x86_64
kernel-2.6.32-251.el6

How reproducible:
Always

Steps to Reproduce:
1.Download the virt-p2v iso from brewweb.

2.Boot the guest with virt-p2v from pxe,input the ip and password of conversion
server,convert it to libvirt.

3.In the conversion page, check if there is a cancel button to interrupt the conversion.

  
Actual results:
There is no cancel button

Expected results:
There should be a cancel button

Additional info:
Comment 2 RHEL Product and Program Management 2012-05-03 00:48:57 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 Richard W.M. Jones 2015-03-12 13:36:08 EDT
New virt-p2v has a cancel button allowing cancellation of
the conversion process.

I'm closing this bug:

 - virt-p2v has been rewritten for RHEL 7.2

 - Unofficial previews of the new version are available:
   http://oirase.annexia.org/virt-p2v/

 - If a similar bug occurs with the new version of virt-p2v,
   please open a new bug against Red Hat Enterprise Linux 7 / libguestfs

Note You need to log in before you can comment on or make changes to this bug.