Bug 808029 - kickstart cannot be mounted on hard drive
Summary: kickstart cannot be mounted on hard drive
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 17
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Will Woods
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-29 11:48 UTC by Hongqing Yang
Modified: 2012-05-07 05:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-07 05:37:54 UTC
Type: ---


Attachments (Terms of Use)
anaconda log (2.21 KB, text/plain)
2012-03-29 11:48 UTC, Hongqing Yang
no flags Details
syslog (51.81 KB, text/plain)
2012-03-29 11:49 UTC, Hongqing Yang
no flags Details
program log (31.27 KB, text/plain)
2012-03-29 11:52 UTC, Hongqing Yang
no flags Details
ks file (1.40 KB, text/plain)
2012-03-29 11:54 UTC, Hongqing Yang
no flags Details

Description Hongqing Yang 2012-03-29 11:48:52 UTC
Created attachment 573643 [details]
anaconda log

Description of problem:

this try to cover the test case:
https://fedoraproject.org/wiki/QA:Testcase_Kickstart_Hd_Device_Path_Ks_Cfg

but the kickstart file cannot be mounted, and the kickstart file on the hard drive becomes empty after installation.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. put ks file to hard drive at /boot
2. boot system and direct ks file to hard drive
3. ks file is not mounted and original ks file becomes empty
  
Actual results:


Expected results:


Additional info:

Comment 1 Hongqing Yang 2012-03-29 11:49:57 UTC
Created attachment 573644 [details]
syslog

Comment 2 Hongqing Yang 2012-03-29 11:52:21 UTC
Created attachment 573645 [details]
program log

Comment 3 Hongqing Yang 2012-03-29 11:54:13 UTC
Created attachment 573647 [details]
ks file

Comment 4 Hongqing Yang 2012-03-31 02:31:04 UTC
This should also F17Beta Blocker according article 
7.The installer must be able to use all kickstart delivery methods 

Can anybody else verify this, I have tried many times, but it does not success.

Comment 5 Adam Williamson 2012-04-02 19:16:24 UTC
Discussed at 2012-04-02 QA meeting, functioning as a blocker review meeting.

Agreed that this is accepted as a blocker under the current criterion, "The installer must be able to use all kickstart delivery methods". There is a current proposal to revise the criterion in a way which would exclude this bug, and it has substantial support, but at the same time, a use case has been raised which was not considered in that discussion: virt-install makes it very easy to use initrd injection of a kickstart file, it's just a single parameter to the virt-install command, so this is arguably a much easier kickstart delivery mechanism to use than we previously thought. So we agreed to accept this as a blocker for now and revive the discussion about revising the criterion, with consideration of this newly-considered use case.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 6 Adam Williamson 2012-04-03 00:21:56 UTC
Can't reproduce, though I tested somewhat differently.

I put Beta RC2 onto a USB stick with livecd-iso-to-disk . Then I copied a kickstart file to the partition labelled LIVE-REPO on the USB stick - the one which just gets the DVD ISO image stuck into it. Then I attached the stick to my test machine, booted, and edited the cmdline to add:

ks=repo:hd:UUID=(copied from the repo= parameter):/kickstart.ks

anaconda booted successfully and clearly loaded the kickstart, as it skipped straight to disk scanning step (and popped up an 'error parsing kickstart config', as the kickstart wasn't correct for the system I was testing on).

So I'm going to change my vote to -1 blocker here: wwoods tested and couldn't reproduce, I tested and couldn't reproduce, and Tao Wu reported success on this test case in the matrix too. I'm wondering if there may still be a valid bug here but a more specific one, to do with exactly how Hongqing tried to test?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Adam Williamson 2012-04-04 01:54:55 UTC
Discussed again at 2012-04-03 emergency blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-04-03/fedora-meeting.2012-04-03-23.08.html .

We are pretty sure we now have three 'passes' for this test - one from me, one from Will, and one from twu as listed on the RC2 install validation matrix. The only person for whom it failed is Hongqing. So we think the mechanism isn't completely broken, indeed it works in most cases, and so this is no longer considered a blocker.

Will did fix some apparent bugs in the code which may have caused this to fail for hongqing, so it may work for him with Beta RC3.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.