Bug 808072 - AK available subscriptions contains also list of already subscribed virtual pools
AK available subscriptions contains also list of already subscribed virtual p...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
medium Severity high (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 09:34 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 15:48:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt. subscriptions (63.80 KB, image/png)
2012-03-29 09:34 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Garik Khachikyan 2012-03-29 09:34:47 EDT
Created attachment 573673 [details]
virt. subscriptions

Description of problem:
One creating new activation key could notice a confusing behavior: there are actually listing "virtual" subscription pools as well together with physical RHEL subscriptions.

Version-Release number of selected component (if applicable):
Latest CFSE beta6candidate
katello-certs-tools-1.0.4-1.el6.noarch
katello-glue-candlepin-0.1.306-1.el6.noarch
candlepin-tomcat6-0.5.26-1.el6.noarch
qpid-cpp-client-0.12-6.el6.x86_64
pulp-1.0.0-4.el6.noarch
katello-selinux-0.1.8-1.el6.noarch
qpid-cpp-client-ssl-0.12-6.el6.x86_64
katello-agent-0.17-1.el6.noarch
katello-cli-tests-0.1.27-1.git.0.5070dfd.el6.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64
katello-common-0.1.306-1.el6.noarch
candlepin-0.5.26-1.el6.noarch
katello-configure-0.1.104-1.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-selinux-server-1.0.0-4.el6.noarch
python-isodate-0.4.4-4.pulp.el6.noarch
katello-glue-pulp-0.1.306-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
python-qpid-0.12-1.el6.noarch
pulp-common-1.0.0-4.el6.noarch
katello-glue-foreman-0.1.306-1.el6.noarch
qpid-cpp-server-0.12-6.el6.x86_64
katello-0.1.306-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
qpid-cpp-server-ssl-0.12-6.el6.x86_64
katello-cli-common-0.1.107-1.el6.noarch
katello-cli-0.1.107-1.el6.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64

How reproducible:
always 

Steps to Reproduce:
1.do import manifest which contain 2 subscriptions of "Red Hat Enterprise Linux Server, Self-support (1-2 sockets) (Up to 1 guest)"
2.consume all 2 "physical" subscriptions.
3.add AK. refer to "Available Subscriptions" expand "Red Hat Enterprise Linux Server, Self-support (1-2 sockets) (Up to 1 guest)"
  
Actual results:
you see there available "virtual subscriptions" as well.

Expected results:
virtual subscriptions can not be assigned through AK (IMO)

Additional info: 
attachment
Comment 1 Tom McKay 2012-05-02 14:40:28 EDT
I believe this it is intentional to show all subscriptions, regardless of current consumption. When a system attempts to register with an AK it is at that time that the checks for available quantity are performed.
Comment 2 Garik Khachikyan 2012-05-03 03:23:30 EDT
for subscriptions, I believe there exists another place to view them - not sure that the AK pages should display the virt. subscriptions (as they are not "consumable" in a regular way)
Comment 3 Tom McKay 2012-05-10 15:48:13 EDT
This is working as intended. No restrictions are meant for what can be put into an activation key.
Comment 5 Mike McCune 2013-08-16 13:54:06 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.