This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 808080 - [abrt] gjs-1.31.10-2.fc17: columnMallocFailure: Process /usr/bin/gjs-console was killed by signal 11 (SIGSEGV)
[abrt] gjs-1.31.10-2.fc17: columnMallocFailure: Process /usr/bin/gjs-console ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-documents (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Elad Alfassa
Fedora Extras Quality Assurance
abrt_hash:8f8412f8e635e4e255d90971c40...
:
: 807293 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 10:10 EDT by S Mac Aodha
Modified: 2012-04-10 13:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 13:22:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (14.51 KB, text/plain)
2012-03-29 10:10 EDT, S Mac Aodha
no flags Details
File: maps (56.58 KB, text/plain)
2012-03-29 10:10 EDT, S Mac Aodha
no flags Details
File: backtrace (32.48 KB, text/plain)
2012-03-29 10:10 EDT, S Mac Aodha
no flags Details

  None (edit)
Description S Mac Aodha 2012-03-29 10:10:04 EDT
libreport version: 2.0.10
abrt_version:   2.0.9
backtrace_rating: 4
cmdline:        /usr/bin/gjs-console -I /usr/share/gnome-documents/js -c 'const SearchProvider = imports.shellSearchProvider; SearchProvider.start();'
crash_function: columnMallocFailure
executable:     /usr/bin/gjs-console
kernel:         3.3.0-5.fc17.x86_64
pid:            2070
pwd:            /
remote_result:  807737
time:           Thu 29 Mar 2012 02:49:42 PM IST
uid:            1000
username:       sean
xsession_errors: 

backtrace:      Text file, 33260 bytes
dso_list:       Text file, 14860 bytes
maps:           Text file, 57938 bytes

core_backtrace:
:63b8b24e78f9956bfba3d0a95500d9a25e21d594 0x2ab71 - libsqlite3.so.0 -
:63b8b24e78f9956bfba3d0a95500d9a25e21d594 0x2ad54 sqlite3_column_value libsqlite3.so.0 -
:9e27816c18322e53c8465a18aa3a8043f3434781 0x54a4e tracker_db_cursor_get_string libtracker-data.so.0 -
:7c35310fc506498c612d5d982ab03becc4b4817c 0x5e90 ffi_call_unix64 libffi.so.5 -
:7c35310fc506498c612d5d982ab03becc4b4817c 0x58a0 ffi_call libffi.so.5 -
:e884a73dd41c0730ee1db883bcbacf2ea362d435 0x2134e - libgjs.so.0 -
:e884a73dd41c0730ee1db883bcbacf2ea362d435 0x22933 - libgjs.so.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xd781e - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xc1840 - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xd56bf - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xd7632 - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xab75d - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xcb946 - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xd56bf - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xd7632 - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xd7c64 - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0x4d2fe JS_CallFunctionValue libmozjs185.so.1.0 -
:e884a73dd41c0730ee1db883bcbacf2ea362d435 0x155fc gjs_call_function_value libgjs.so.0 -
:e884a73dd41c0730ee1db883bcbacf2ea362d435 0x2015f gjs_closure_invoke libgjs.so.0 -
:e884a73dd41c0730ee1db883bcbacf2ea362d435 0x29d99 - libgjs.so.0 -
:e850c9c2577f79b97ad4c53dbf9b0964682dcbaa 0xf804 g_closure_invoke libgobject-2.0.so.0 -
:e850c9c2577f79b97ad4c53dbf9b0964682dcbaa 0x214e8 - libgobject-2.0.so.0 -
:e850c9c2577f79b97ad4c53dbf9b0964682dcbaa 0x295da g_signal_emit_valist libgobject-2.0.so.0 -
:e850c9c2577f79b97ad4c53dbf9b0964682dcbaa 0x297c2 g_signal_emit libgobject-2.0.so.0 -
:a9eb9e4d2da6b047bad0601ad65f06ea8afb3603 0xdc1d6 - libgio-2.0.so.0 -
:a9eb9e4d2da6b047bad0601ad65f06ea8afb3603 0xc3d18 - libgio-2.0.so.0 -
:652697d945b4084f8ecf3bbd2eeb5d33b69aff4f 0x4773c g_main_context_dispatch libglib-2.0.so.0 -
:652697d945b4084f8ecf3bbd2eeb5d33b69aff4f 0x47b58 - libglib-2.0.so.0 -
:652697d945b4084f8ecf3bbd2eeb5d33b69aff4f 0x47f42 g_main_loop_run libglib-2.0.so.0 -
:330b5dcff8db36ab09d676ed08b63ece6db34aaa 0x1bc9 - mainloop.so -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xcb946 - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xd56bf - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0xd63a3 - libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0x4d96f JS_EvaluateUCScriptForPrincipals libmozjs185.so.1.0 -
:cf1bb78fe29e55a36a922c712f5a2404ec8e3272 0x4dc62 JS_EvaluateUCScript libmozjs185.so.1.0 -
:e884a73dd41c0730ee1db883bcbacf2ea362d435 0x11e97 gjs_context_eval libgjs.so.0 -
:bc9b2babe1e3892d956c99247744ba428fdb264d 0xf2e main [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-0vXjwBrcj8,guid=8c9948aaf661dd18936da2610000002c
:GPG_AGENT_INFO=/tmp/keyring-g1qM5G/gpg:0:1
:SHELL=/bin/bash
:GNOME_KEYRING_CONTROL=/tmp/keyring-g1qM5G
:USER=sean
:LD_LIBRARY_PATH=/usr/lib64/gnome-documents
:SSH_AUTH_SOCK=/tmp/keyring-g1qM5G/ssh
:GJS_PATH=/usr/share/gnome-documents/js
:
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/998,unix/unix:/tmp/.ICE-unix/998
:PATH=/usr/local/bin:/usr/bin:/bin
:DESKTOP_SESSION=gnome
:PWD=/
:LANG=en_US.utf8
:GNOME_KEYRING_PID=994
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:DBUS_STARTER_BUS_TYPE=session
:HOME=/home/sean
:SHLVL=2
:XDG_SEAT=seat0
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=sean
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-0vXjwBrcj8,guid=8c9948aaf661dd18936da2610000002c
:WINDOWPATH=1
:GI_TYPELIB_PATH=/usr/lib64/gnome-documents/girepository-1.0
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/sean
:XAUTHORITY=/var/run/gdm/auth-for-sean-JABWFu/database
:_=/usr/bin/gjs-console

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 21889                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       21889                21889                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100002
:1:/dev/null
:pos:	0
:flags:	0100002
:2:/dev/null
:pos:	0
:flags:	0100002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:/dev/null
:pos:	0
:flags:	0100002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:socket:[69590]
:pos:	0
:flags:	02004002
:7:anon_inode:inotify
:pos:	0
:flags:	02004000
:8:socket:[76908]
:pos:	0
:flags:	02004002
:9:socket:[76904]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:/home/sean/.cache/tracker/meta.db
:pos:	36657152
:flags:	02100000
:12:/home/sean/.cache/tracker/meta.db-wal
:pos:	129984
:flags:	02100002
:13:/home/sean/.cache/tracker/meta.db-shm
:pos:	0
:flags:	0100002
:14:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:15:socket:[69593]
:pos:	0
:flags:	02004002
:16:/dev/urandom
:pos:	0
:flags:	02100000

var_log_messages:
:Mar 29 01:13:07 acer-as5552 kernel: [ 1433.243777] gjs-console[4994]: segfault at 58 ip 0000003196a2ab71 sp 00007fff039704c8 error 4 in libsqlite3.so.0.8.6[3196a00000+9e000]
:Mar 29 01:13:08 acer-as5552 abrt[5033]: Saved core dump of pid 4994 (/usr/bin/gjs-console) to /var/spool/abrt/ccpp-2012-03-29-01:13:07-4994 (85700608 bytes)
:Mar 29 14:49:42 acer-as5552 kernel: [  518.226722] gjs-console[2070]: segfault at 58 ip 0000003196a2ab71 sp 00007fff3f3a1b48 error 4 in libsqlite3.so.0.8.6[3196a00000+9e000]
:Mar 29 14:49:43 acer-as5552 abrt[2253]: Saved core dump of pid 2070 (/usr/bin/gjs-console) to /var/spool/abrt/ccpp-2012-03-29-14:49:42-2070 (70897664 bytes)
Comment 1 S Mac Aodha 2012-03-29 10:10:09 EDT
Created attachment 573679 [details]
File: dso_list
Comment 2 S Mac Aodha 2012-03-29 10:10:12 EDT
Created attachment 573680 [details]
File: maps
Comment 3 S Mac Aodha 2012-03-29 10:10:15 EDT
Created attachment 573681 [details]
File: backtrace
Comment 4 Cosimo Cecchi 2012-04-10 13:22:20 EDT
This was fixed upstream in gnome-documents 0.3.4.
Comment 5 Cosimo Cecchi 2012-04-10 13:24:35 EDT
*** Bug 807293 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.