Bug 808099 - Unhelpful error message is displayed when no value is given in --revocation-reason optional argument with "ipa cert-revoke"
Unhelpful error message is displayed when no value is given in --revocation-r...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 11:07 EDT by Kaleem
Modified: 2012-06-20 09:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: ipa-2.2.0-9.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:26:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleem 2012-03-29 11:07:25 EDT
Description of problem:
When no value is provided to --revocation-reason argument in ipa cert_revoke, following unhelpful error message displayed.

[root@ipa63server ipa-cert]# ipa cert-revoke 5 --revocation-reason=
ipa: ERROR: an internal error has occurred
[root@ipa63server ipa-cert]

Version-Release number of selected component (if applicable):

[root@ipa63server ipa-cert]# rpm -q ipa-server
ipa-server-2.2.0-5.el6.x86_64
[root@ipa63server ipa-cert]#

How reproducible:
Always

Steps to Reproduce:
1.Install IPA server
2.Try to revoke certificate with 'ipa cert-revoke' and provide no value to --revocation-reason optional argument.
[root@ipa63server ipa-cert]# ipa cert-revoke 5 --revocation-reason=
ipa: ERROR: an internal error has occurred
[root@ipa63server ipa-cert

  
Actual results:
Got following error message
"ipa: ERROR: an internal error has occurred"

Expected results:
Some helpful error message should be displayed
Comment 2 Martin Kosek 2012-03-30 02:04:17 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2597
Comment 6 Kaleem 2012-04-17 07:43:24 EDT
Verified.

ipa-server version:
[root@ipa63server ~]# rpm -q ipa-server
ipa-server-2.2.0-9.el6.x86_64
[root@ipa63server ~]#

Now proper error message is displayed when empty --revocation-reason is provided.

[root@ipa63server ~]# ipa cert_revoke 5 --revocation-reason=
ipa: ERROR: 'revocation_reason' is required
[root@ipa63server ~]#

Automated:

:: [   PASS   ] :: clear kerberos tkts
service_12812/ipa63server.testrelm.com=12
12
ipa: ERROR: 'revocation_reason' is required
:: [   PASS   ] :: revocation_reason argument can not be empty
0xC
0xC
ipa: ERROR: 'revocation_reason' is required
:: [   PASS   ] :: revocation_reason argument can not be empty
Comment 8 Martin Kosek 2012-04-25 07:18:15 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 10 errata-xmlrpc 2012-06-20 09:26:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.