Bug 808198 - prevent kernel rpms from getting installed on ec2 RHEL 5x ami's
prevent kernel rpms from getting installed on ec2 RHEL 5x ami's
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng (Show other bugs)
5.8
Unspecified Unspecified
urgent Severity urgent
: rc
: 5.9
Assigned To: wes hayutin
Release Test Team
: EC2
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 15:31 EDT by wes hayutin
Modified: 2013-01-08 02:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:10:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2012-03-29 15:31:48 EDT
Description of problem:

Prevent kernel rpms from getting installed on ec2 RHEL 5x ami's.
Only kernel-xen should be allowed.


Thanks
Comment 1 RHEL Product and Program Management 2012-04-02 07:21:49 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 James Slagle 2012-10-31 15:07:30 EDT
I added a exclude=kernel* to the yum config for the rhel yum repo config for rhel 5.  Let me know if any other changes are needed.

This has been built into https://brewweb.devel.redhat.com/buildinfo?buildID=241277
Comment 6 James Slagle 2012-11-27 12:36:01 EST
I rebuilt the rpm's with this change:
https://brewweb.devel.redhat.com/buildinfo?buildID=245402
Comment 8 Kevin Wright 2012-11-28 18:26:32 EST
uploaded:

Starter|i386  |us-east-1| hourly|EBS| EBS Image| ?? | ami-7700811e | pending
Starter|x86_64|us-east-1| hourly|EBS| EBS Image| ?? | ami-b90382d0 | pending
Comment 12 errata-xmlrpc 2013-01-08 02:10:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0021.html

Note You need to log in before you can comment on or make changes to this bug.