Bug 808227 - It's not clear how to get help working with scilab
It's not clear how to get help working with scilab
Status: CLOSED DUPLICATE of bug 767102
Product: Fedora
Classification: Fedora
Component: scilab (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Clément DAVID
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 17:13 EDT by James
Modified: 2012-12-10 04:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 04:43:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2012-03-29 17:13:59 EDT
I'm not sure where to file this. Installing scilab via the Add/Remove Software does not install the help system so all the help commands return an error. It is not clear how to fix this because searching for 'scilab' using Add/Remove Software only returns one result, the tool itself.

I was able to discover scilab-doc through a comment on the linked bug, via a web search. Strangely, 'yum list "scilab*" and Yum Extender both return all 6 packages with scilab in the name. 

This behavior is not consistent with similar tools like Octave. Installing only the Octave base package includes the in-tool help commands.
Comment 1 Clément DAVID 2012-12-10 04:43:59 EST
The scilab-doc package comply with the packaging guidelines [1] and reduce the scilab package from around 100M down to 13M which is much more acceptable for some users.

Please note that octave packaging reduce the global size by splitting the software in many functionality-oriented packages.

On rawhide, a patch is provided to use pkcon on help() invocation and without the scilab-doc package.

[1]: https://fedoraproject.org/wiki/Packaging:Guidelines#Documentation

*** This bug has been marked as a duplicate of bug 767102 ***

Note You need to log in before you can comment on or make changes to this bug.