Bug 808264 - [abrt] xfdesktop-4.8.3-1.fc16: FcCompare: Process /usr/bin/xfdesktop was killed by signal 11 (SIGSEGV)
[abrt] xfdesktop-4.8.3-1.fc16: FcCompare: Process /usr/bin/xfdesktop was kill...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xfdesktop (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
abrt_hash:1647a70cd4263a138b20b07dfb4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 20:58 EDT by chrisantonick
Modified: 2012-03-30 11:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 11:34:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (6.22 KB, text/plain)
2012-03-29 20:58 EDT, chrisantonick
no flags Details
File: maps (23.69 KB, text/plain)
2012-03-29 20:58 EDT, chrisantonick
no flags Details
File: backtrace (52.22 KB, text/plain)
2012-03-29 20:58 EDT, chrisantonick
no flags Details

  None (edit)
Description chrisantonick 2012-03-29 20:58:45 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        xfdesktop --display :0.0 --sm-client-id 227e2e45f-3386-4244-9508-ce0506aee868
crash_function: FcCompare
executable:     /usr/bin/xfdesktop
kernel:         3.3.0-4.fc16.i686
pid:            1669
pwd:            /home/chris
reason:         Process /usr/bin/xfdesktop was killed by signal 11 (SIGSEGV)
time:           Thu 29 Mar 2012 07:08:47 PM CDT
uid:            1000
username:       chris

backtrace:      Text file, 53475 bytes
dso_list:       Text file, 6372 bytes
maps:           Text file, 24256 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:SSH_AGENT_PID=1611
:HOSTNAME=localhost.localdomain
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/home/chris/.gnupg/S.gpg-agent:1652:1
:GLADE_PIXMAP_PATH=:
:XDG_MENU_PREFIX=xfce-
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=94c50acdd00b04194c9b184200000085-1332719127.36948-438205895
:GNOME_KEYRING_CONTROL=/tmp/keyring-Tz2CP5
:IMSETTINGS_MODULE=none
:USER=chris
:GLADE_MODULE_PATH=:
:SSH_AUTH_SOCK=/tmp/ssh-UqMvXskF1467/agent.1467
:USERNAME=chris
:XDG_CONFIG_DIRS=/etc/xdg
:MAIL=/var/spool/mail/chris
:DESKTOP_SESSION=xfce
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/chris/.local/bin:/home/chris/bin
:QT_IM_MODULE=xim
:PWD=/home/chris
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=1463
:GDMSESSION=xfce
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/chris
:LOGNAME=chris
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-5msAARvyoA,guid=691103ef9d84b4e56be24d550000022f
:XDG_DATA_DIRS=/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/chris
:GLADE_CATALOG_PATH=:
:LIBGLADE_MODULE_PATH=:
:XAUTHORITY=/var/run/gdm/auth-for-chris-DxN3ey/database
:_=/usr/bin/xfce4-session
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1661,unix/unix:/tmp/.ICE-unix/1661

smolt_data:
:
:
:General
:=================================
:UUID: c4c37c2d-c01f-4563-87a9-150ba4badbd3
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 3590.86
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Turion(tm) 64 X2 Mobile Technology TL-56
:CPU Stepping: 2
:CPU Family: 15
:CPU Model Num: 72
:Number of CPUs: 2
:CPU Speed: 1800
:System Memory: 1889
:System Swap: 3775
:Vendor: Dell Inc.
:System: Inspiron 1501 Not Specified
:Form factor: Portable
:Kernel: 3.3.0-4.fc16.i686
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:23096:4098:22864) pci, pcieport, PCI/PCI, RS480 PCI Bridge
:(4098:17289:4136:501) pci, ohci_hcd, USB, SB600 USB (OHCI2)
:(5348:5900:4136:501) pci, b44, ETHERNET, BCM4401-B0 100Base-TX
:(4480:2115:4136:501) pci, sdhci-pci, BASE, Dell Inspiron 1501
:(4480:2082:4136:501) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(4098:22864:4136:501) pci, None, HOST/PCI, RS480 Host Bridge
:(4098:23103:4098:23103) pci, None, PCI/PCI, RS480 PCI Bridge
:(4130:4353:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] Address Map
:(4130:4352:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
:(4130:4355:0:0) pci, k8temp, HOST/PCI, K8 [Athlon64/Opteron] Miscellaneous Control
:(4130:4354:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] DRAM Controller
:(4098:17280:4136:501) pci, ahci, STORAGE, SB600 Non-Raid-5 SATA
:(4098:17292:4136:501) pci, pata_atiixp, STORAGE, SB600 IDE
:(4098:17285:4136:501) pci, piix4_smbus, SERIAL, SBx00 SMBus Controller
:(4098:17293:4136:501) pci, None, PCI/ISA, SB600 PCI to LPC Bridge
:(4098:17283:4136:501) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4098:22901:4136:501) pci, radeon, VIDEO, RS482 [Radeon Xpress 200M]
:(4098:17290:4136:501) pci, ohci_hcd, USB, SB600 USB (OHCI3)
:(4098:17287:4136:501) pci, ohci_hcd, USB, SB600 USB (OHCI0)
:(4098:17288:4136:501) pci, ohci_hcd, USB, SB600 USB (OHCI1)
:(4098:17291:4136:501) pci, ohci_hcd, USB, SB600 USB (OHCI4)
:(4098:17286:4136:501) pci, ehci_hcd, USB, SB600 USB Controller (EHCI)
:(5348:17169:4136:7) pci, b43-pci-bridge, NETWORK, Wireless 1390 WLAN Mini-Card
:(4098:23095:4098:22864) pci, pcieport, PCI/PCI, RS480 PCI Bridge
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup-lv_root / ext4 4096 4096 2993712 1485021 1455050 753664 582847 582847
:/dev/sda5 /boot ext4 1024 1024 508745 410065 384465 128016 127740 127740
:/dev/sdc2 WITHHELD ext2 4096 4096 49874395 46909135 44374889 12673024 12639800 12639800
:/dev/sdc2 WITHHELD ext2 4096 4096 49874395 46909135 44374889 12673024 12639800 12639800
:

var_log_messages:
:Mar 29 19:08:47 localhost kernel: [69255.685083] xfdesktop[1669]: segfault at e030b778 ip 49b5d492 sp bfd75530 error 5 in libfontconfig.so.1.4.4[49b48000+33000]
:Mar 29 19:08:47 localhost abrt[17880]: File '/usr/bin/xfdesktop' seems to be deleted
:Mar 29 19:08:48 localhost abrt[17880]: Saved core dump of pid 1669 (/usr/bin/xfdesktop) to /var/spool/abrt/ccpp-2012-03-29-19:08:47-1669 (13443072 bytes)
:Mar 29 19:08:48 localhost kernel: [69256.826685] EXT4-fs error (device dm-1): ext4_free_inode:289: comm xfdesktop: bit already cleared for inode 35566
:Mar 29 19:08:48 localhost kernel: [69256.826989] EXT4-fs error (device dm-1): ext4_free_inode:289: comm xfdesktop: bit already cleared for inode 54325
Comment 1 chrisantonick 2012-03-29 20:58:48 EDT
Created attachment 573847 [details]
File: dso_list
Comment 2 chrisantonick 2012-03-29 20:58:50 EDT
Created attachment 573848 [details]
File: maps
Comment 3 chrisantonick 2012-03-29 20:58:52 EDT
Created attachment 573849 [details]
File: backtrace
Comment 4 Kevin Fenzi 2012-03-29 23:16:27 EDT
Odd: 

:Mar 29 19:08:48 localhost kernel: [69256.826685] EXT4-fs error (device dm-1):
ext4_free_inode:289: comm xfdesktop: bit already cleared for inode 35566
:Mar 29 19:08:48 localhost kernel: [69256.826989] EXT4-fs error (device dm-1):
ext4_free_inode:289: comm xfdesktop: bit already cleared for inode 54325

sounds like disk errors. Is your disk having issues? 

Can you duplicate this issue?
Comment 5 chrisantonick 2012-03-29 23:52:14 EDT
(In reply to comment #4)

> sounds like disk errors. Is your disk having issues? 
> 
> Can you duplicate this issue?

I don't know if I can duplicate it.  What happened was that I was installing eclipse-platform via yum, and it crashed somewhere along the way.  I had to run fsck when I rebooted.  Everything is fine now.
Comment 6 Kevin Fenzi 2012-03-30 11:34:24 EDT
ok, I think this was related to the disk issues... please reopen if you see it again.

Note You need to log in before you can comment on or make changes to this bug.