Bug 808267 - [abrt] bodhi-client-0.8.5-1.fc16: ini.py:565:_readfp:MissingSectionHeaderError: File contains no section headers.
[abrt] bodhi-client-0.8.5-1.fc16: ini.py:565:_readfp:MissingSectionHeaderErro...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bodhi (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
abrt_hash:26db38721cb9cd3fd0a2d0cc13f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-29 21:27 EDT by Xibo Ning
Modified: 2016-09-19 22:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 23:39:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xibo Ning 2012-03-29 21:27:14 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python -tt /usr/bin/bodhi --new --release el6 --file bodhi.template perl-Pod-Plainer-1.03-1.el6 --username xning
executable:     /usr/bin/bodhi
kernel:         3.3.0-4.fc16.x86_64
reason:         ini.py:565:_readfp:MissingSectionHeaderError: File contains no section headers.
time:           Wed 28 Mar 2012 12:09:02 PM CST
uid:            1000
username:       tsllst

backtrace:
:ini.py:565:_readfp:MissingSectionHeaderError: File contains no section headers.
:file: bodhi.template, line: 1
:'\t[ perl-Pod-Plainer-1.03-1.el6 ]                                                                 \n'
:
:Traceback (most recent call last):
:  File "/usr/bin/bodhi", line 519, in <module>
:    main()
:  File "/usr/bin/bodhi", line 201, in main
:    updates = bodhi.parse_file(input_file=opts.input_file)
:  File "/usr/lib/python2.7/site-packages/fedora/client/bodhi.py", line 281, in parse_file
:    config.readfp(template_file)
:  File "/usr/lib/python2.7/site-packages/iniparse/compat.py", line 111, in readfp
:    self.data._readfp(fp)
:  File "/usr/lib/python2.7/site-packages/iniparse/ini.py", line 565, in _readfp
:    raise MissingSectionHeaderError(fname, linecount, line)
:MissingSectionHeaderError: File contains no section headers.
:file: bodhi.template, line: 1
:'\t[ perl-Pod-Plainer-1.03-1.el6 ]                                                                 \n'
:
:Local variables in innermost frame:
:pending_lines: []
:fp: <open file 'bodhi.template', mode 'r' at 0x13c4c90>
:exc: None
:cur_option: None
:self: <iniparse.ini.INIConfig object at 0x14413d0>
:cur_section_name: None
:cur_section: None
:linecount: 1
:cur_option_name: None
:fname: 'bodhi.template'
:lineobj: <iniparse.ini.ContinuationLine object at 0x14419d0>
:pending_empty_lines: False
:line: '\t[ perl-Pod-Plainer-1.03-1.el6 ]                                                                 \n'

smolt_data:
:
:
:General
:=================================
:UUID: 8e4165a3-9614-4b1e-9f81-cbd22c0e1795
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6784.09
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 8
:CPU Speed: 3401
:System Memory: 7813
:System Swap: 4135
:Vendor: LENOVO
:System: ThinkCentre M8300T Lenovo Product
:Form factor: Desktop
:Kernel: 3.3.0-4.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:258:6058:12400) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7170:6058:12400) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7246:6058:12400) pci, None, PCI/ISA, Q67 Express Chipset Family LPC Controller
:(32902:7200:6058:12400) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5378:6058:12400) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7213:6058:12400) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7202:6058:12400) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:9294:6058:12400) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:7229:6058:12400) pci, serial, 16550_SERIAL, 6 Series/C200 Series Chipset Family KT Controller
:(32902:7206:6058:12400) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:256:6058:12400) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:12400) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup-LogVol00 / ext4 4096 4096 120779208 107461170 101415730 30228480 29888536 29888536
:/dev/sda1 /boot ext4 1024 1024 508745 409047 383447 128016 127786 127786
:
Comment 1 Luke Macken 2012-03-30 13:47:40 EDT
It looks like you put a tab before the [ perl-Pod-Plainer-1.03-1.el6 ] header. Can you try without that and see if that works as expected?
Comment 2 Xibo Ning 2012-03-30 22:00:16 EDT
Hi, Luke. you mean I put a tab before the package name in the spec file, so I need remove it, right?
Comment 3 Luke Macken 2012-03-30 22:51:07 EDT
No, it seems that your bodhi update template is getting parsed as:

'\t[ perl-Pod-Plainer-1.03-1.el6 ]                                            
                    \n'

Can you ensure that the \t doesn't exist and see if the problem still occurs?
Comment 4 Xibo Ning 2012-03-30 23:39:07 EDT
Hi, Luke. I don't fill bodhi.template well, so bodhi don't work. It works well now. Thanks a lot.

Note You need to log in before you can comment on or make changes to this bug.