Bug 808294 - Build dependency error
Summary: Build dependency error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-unikey
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Truong Anh Tuan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-30 05:06 UTC by Akira TAGOH
Modified: 2012-04-14 04:31 UTC (History)
1 user (show)

Fixed In Version: ibus-unikey-0.6.1-2.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-14 04:31:51 UTC
Type: ---


Attachments (Terms of Use)

Description Akira TAGOH 2012-03-30 05:06:22 UTC
Description of problem:
As the daily report said (http://lists.fedoraproject.org/pipermail/devel/2012-March/165066.html) ibus-unikey has a problem on its deps now.

[ibus-unikey]
	ibus-unikey-0.6.1-1.fc17.x86_64 requires libibus-1.0.so.0()(64bit)

ibus-unikey needs to be rebuilt against the latest ibus.

there are the same problem in rawhide too.

Comment 1 Truong Anh Tuan 2012-04-02 15:05:12 UTC
Hi there,

I get this message every day.
However, there is no error when I tried to compile locally (using mock build)

Anyone can explain more to me what's happen and how to solve it?

Rgds,
Tuan

Comment 2 Akira TAGOH 2012-04-03 03:51:48 UTC
because you don't have ibus-1.4.99.20120317 installed locally. you can try koji scratch-build to see instead.

Comment 3 Truong Anh Tuan 2012-04-03 08:02:43 UTC
I tried a scratch-build:

[tuanta@tuanta ibus-unikey]$ fedpkg srpm; koji build --scratch --arch-override x86_64 f17 ibus-unikey-0.6.1-1.fc16.src.rpm

It's success: http://koji.fedoraproject.org/koji/taskinfo?taskID=3958952

Could you tell me what I should consider more?

Comment 4 Akira TAGOH 2012-04-03 09:23:04 UTC
check if the package is surely linked against libibus-1.0.so.5. if not, you need to request the buildroot overrides on bodhi.

Comment 5 Truong Anh Tuan 2012-04-06 03:47:24 UTC
I tried the way in [1] to submit a new override at [2], but I got this error message: "Error: ibus-unikey-0.6.1-1.fc17 is already tagged with f17".

Could you tell me what I should do next?

[1] http://fedoraproject.org/wiki/Bodhi/BuildRootOverrides
[2] https://admin.fedoraproject.org/updates/override/new

Comment 6 Truong Anh Tuan 2012-04-06 04:07:29 UTC
That message is shown when I specify "--buildroot-override=ibus-unikey-0.6.1-1.fc17".
When I specify "--buildroot-override=ibus-unikey-0.6.1-1.fc18", it shows another error message: "Error: Could not determine release for ibus-unikey-0.6.1-1.fc18 with tags ['f18']".

Please help me. Tia.

Rgds,
Tuan

Comment 7 Akira TAGOH 2012-04-06 05:16:30 UTC
The buildroot overrides feature is basically to request to install a library on the buildroot, which isn't pulled into it because it's not yet available in stable etc. so requesting ibus-unikey for buildroot overrides doesn't help at all.

Apparently the build you did in comment#3 has been linked against libibus-1.0.so.5. so you don't need to do it at this moment.

also note that scratch-build isn't official build but it's just only for testing purpose. so it won't be tagged with any releases.

Anyway I suppose you can go ahead without it. once you build it for devel, you can check tomorrow's report for devel at least. and need to wait for f17 until beta is out, even if you file an update on bodhi and requesting to push into stable.

HTH

Comment 8 Truong Anh Tuan 2012-04-06 06:33:16 UTC
Thank you for your response.
However, it doesn't make sense to me. Sorry :)

This means I don't need to do anything? Or I need to rebuild the package for rawhide? Or...?

TIA
Tuan

Comment 9 Akira TAGOH 2012-04-06 08:27:20 UTC
You have to rebuild ibus-unikey for f17 and rawhide as you are getting email about broken deps. the buildroot overrides is to ensure stop it after rebuilding. to make more clearer, if the certain library isn't on the buildroot, you'll still get  the broken deps warning after rebuild. that's it.

Comment 10 Truong Anh Tuan 2012-04-06 09:47:05 UTC
Thanks. I have done "fedpkg scratch-build" for both f17 [1] and rawhide [2].

One more question: do I need to do "fedpkg update" again?

Tia.
Tuan

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=3968343
[2] http://koji.fedoraproject.org/koji/taskinfo?taskID=3968348

Comment 11 Akira TAGOH 2012-04-06 11:09:47 UTC
You better read comment#7 carefully. what you have to do at this moment is "koji build" but not "koji scratch-build" and file an update on bodhi after that.

Comment 12 Truong Anh Tuan 2012-04-07 02:48:20 UTC
Before doing a scratch-build, I had tried to do "fedpkg build" but I got this error message "Could not execute build: ibus-unikey-0.6.1-1.fc18 has already been built" (for both f17 and rawhide).

Any more helps?

Comment 13 Akira TAGOH 2012-04-09 02:01:05 UTC
You have to bump the release number as usual.

Comment 14 Truong Anh Tuan 2012-04-09 02:22:54 UTC
You meant "--target" option should be used?
I have just tried that, still got the same error messages.

Comment 15 Akira TAGOH 2012-04-09 02:48:17 UTC
NO. the release number in the spec file. do not forget to add a changelog too.

Comment 16 Truong Anh Tuan 2012-04-09 02:55:31 UTC
Understood. Thank you so much :)
I will update now.

Comment 17 Fedora Update System 2012-04-09 03:32:15 UTC
ibus-unikey-0.6.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-unikey-0.6.1-2.fc17

Comment 18 Fedora Update System 2012-04-10 20:20:36 UTC
Package ibus-unikey-0.6.1-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-unikey-0.6.1-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5602/ibus-unikey-0.6.1-2.fc17
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2012-04-14 04:31:51 UTC
ibus-unikey-0.6.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.