Bug 808301 - When kill virt-p2v-server process during conversion of virt-p2v,the client has no messages prompted and no messages logged
When kill virt-p2v-server process during conversion of virt-p2v,the client ha...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 01:42 EDT by tingting zheng
Modified: 2015-03-12 13:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-12 13:44:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2012-03-30 01:42:31 EDT
Description of Problem:
When kill virt-p2v-server process during conversion of virt-p2v,the client has no messages prompted and no messages logged

Version-Release number of selected component:
virt-v2v-0.8.7-4.el6.x86_64
rubygem-virt-p2v-0.8.6-2.el6


How reproducible:
Always

Step to Reproduce:
1.Download the virt-p2v iso from brewweb.

2.Configured /usr/bin/virt-p2v-server as:
# Initialize logging
logmsg_init('syslog');
logmsg_level(DEBUG);

# Uncomment these 2 lines to capture debug information from the conversion
# process
$ENV{'LIBGUESTFS_DEBUG'} = 1;

3.Boot the host with virt-p2v from pxe,input the ip and password of conversion server

4.During the conversion of virt-p2v,kill virt-p2v-server process manually.

5.Check the virt-p2v client UI,the data stopped to transfer,but no messages printed as:virt-p2v-server exited.

6.Check /var/log/virt-p2v-server.*.log,there is nothing logged.
Check /var/log/messages,there is no messages logged as"virt-p2v-server exited".
Mar 30 12:56:44 tzheng-linux virt-v2v[3922]: p2v-server started.
Mar 30 12:56:44 tzheng-linux virt-v2v[3922]: Received: LIST_PROFILES
Mar 30 12:56:44 tzheng-linux virt-v2v[3922]: Sent: LIST 3#012rhev-sparse#012rhev-preallocated#012libvirt
Mar 30 12:57:17 tzheng-linux virt-v2v[3922]: Received: SET_PROFILE libvirt
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Sent: OK
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Received: METADATA 207
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Read 207 bytes
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Sent: OK
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Received: PATH 16106127360 /dev/xvda
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Pool: $VAR1 = bless( do{\(my $o = 32174736)}, 'Sys::Virt::StoragePool' );
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Sent: OK
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Received: CONTAINER RAW
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Sent: OK
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Received: DATA 16106127360
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Read 4194304 bytes
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Read 4194304 bytes
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Read 4194304 bytes
Mar 30 12:57:18 tzheng-linux virt-v2v[3922]: Read 4194304 bytes
Mar 30 12:57:19 tzheng-linux virt-v2v[3922]: Read 4194304 bytes


Actual Results:
virt-p2v client has no messages prompted and no messages logged.

Expected Results:
There should be some messages prompted and it should be logged.

Additional info:
Comment 2 RHEL Product and Program Management 2012-05-03 00:48:51 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Richard W.M. Jones 2015-03-12 13:44:29 EDT
I'm closing this bug:

 - virt-p2v has been rewritten for RHEL 7.2

 - Unofficial previews of the new version are available:
   http://oirase.annexia.org/virt-p2v/

 - If a similar bug occurs with the new version of virt-p2v,
   please open a new bug against Red Hat Enterprise Linux 7 / libguestfs

Note You need to log in before you can comment on or make changes to this bug.