Bug 808316 - only show 8 vcpus online after hotplugging 160 vcpus for win2008r2 guest
only show 8 vcpus online after hotplugging 160 vcpus for win2008r2 guest
Status: CLOSED DUPLICATE of bug 808313
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 Windows
medium Severity medium
: rc
: ---
Assigned To: Igor Mammedov
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 02:34 EDT by FuXiangChun
Modified: 2012-04-13 10:07 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 10:42:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FuXiangChun 2012-03-30 02:34:31 EDT
Description of problem:
after hotplugging 160 vcpus to guest,Opening Task Manager and going to the Tab 'Performance' will only show 8 vcpus. if rebooting guest, Performance will show 64 vcpus

Version-Release number of selected component (if applicable):
rpm -qa|grep qemu
qemu-kvm-0.12.1.2-2.267.el6.x86_64

uname -r
2.6.32-257.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Steps to Reproduce:
1./usr/libexec/qemu-kvm run -M rhel6.3.0 --enable-kvm -m 4G -smp 1,maxcpus=161
-name rhel6.3 -uuid ddcbfb49-3411-1701-3c36-6bdbc00bedbb -rtc
base=utc,clock=host,driftfix=slew -boot c -drive
file=/dev/vg-qzhang/lv-2k8r2,if=none,id=virtio,format=raw,cache=none,werror=stop,rerror=stop,boot=on
-device virtio-blk-pci,drive=virtio,id=drive-virtio0-0-0,bootindex=1 -netdev
tap,id=hostnet1 -device
virtio-net-pci,netdev=hostnet1,id=net1,mac=32:12:50:a4:32:74 -spice
port=5914,disable-ticketing -vga qxl -device sga -chardev
socket,id=serial0,path=/var/test3,server,nowait -device
isa-serial,chardev=serial0 -monitor unix:/tmp/monitor4,server,nowait -monitor
stdio -qmp tcp:0:6667,server,nowait

2.hotplug with script
i=1
while [ $i -lt 160 ]
do
sleep 2
echo "cpu_set $i online"|nc -U /tmp/monitor4
i=$(($i+1))
done

3.check online vcpus 
Opening Task Manager and going to the Tab 'Performance' 

Actual results:
show 8 vcpus

Expected results:
show 160 vcpus
  

Additional info:
Comment 2 Igor Mammedov 2012-04-03 09:22:26 EDT
likely dup of bug 808313
Comment 3 Ademar Reis 2012-04-09 10:42:30 EDT
Same testcase of Bug 808313, AFAIK. If there are peculiarities in the testcase, please add the notes to the other bug.

*** This bug has been marked as a duplicate of bug 808313 ***

Note You need to log in before you can comment on or make changes to this bug.