Bug 808340 - "undefined method `[]' for nil:NilClass" is seen when trying to create app without domain
"undefined method `[]' for nil:NilClass" is seen when trying to create app wi...
Status: CLOSED DUPLICATE of bug 808318
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
Depends On:
  Show dependency treegraph
Reported: 2012-03-30 03:56 EDT by Johnny Liu
Modified: 2012-03-30 04:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-03-30 04:03:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-03-30 03:56:14 EDT
Description of problem:
$ create_php_app 
/usr/lib/ruby/gems/1.8/gems/rhc-0.89.10/lib/rhc-common.rb:384:in `create_app': undefined method `[]' for nil:NilClass (NoMethodError)
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.89.10/bin/rhc-create-app:248
	from /usr/bin/rhc-create-app:19:in `load'
	from /usr/bin/rhc-create-app:19

Error message is not friendly.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Johnny Liu 2012-03-30 04:03:32 EDT

*** This bug has been marked as a duplicate of bug 808318 ***

Note You need to log in before you can comment on or make changes to this bug.