This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 808354 - Unable to autosubscribe, server does not support service levels
Unable to autosubscribe, server does not support service levels
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: TestBlocker
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-30 04:37 EDT by Marian Ganisin
Modified: 2012-06-20 09:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:08:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Ganisin 2012-03-30 04:37:06 EDT
Description of problem:

Autosubscribe from GUI doesn't work at the moment. It reports:

Unable to autosubscribe, server does not support service levels

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.99.12-1.el6

How reproducible:
always
Comment 3 Bryan Kearney 2012-04-02 21:40:29 EDT
Please re-verify in QA on 06 April.
Comment 4 Bryan Kearney 2012-04-11 09:01:34 EDT
Candlepin has been moved to QA and STAGE. Please re-test.
Comment 6 John Sefler 2012-04-12 19:23:19 EDT
When configured to connect to an old candlepin server (as was the case in comment 1), the server should reply as observed in comment 1.  In fact, comment 1 is actually a re-verification of bug 803778


The candlepin server deployed in the stage environment was upgraded today to candlepin-0.5.26-1.el6.  We can now assert that registering with autosubscribe and a service-level is successful....

[root@jsefler-r63-server ~]# rpm -q subscription-manager
subscription-manager-0.99.14-1.el6.x86_64


[root@jsefler-r63-server ~]# subscription-manager config --server.hostname subscription.rhn.stage.redhat.com
[root@jsefler-r63-server ~]# subscription-manager service-level --list --username stage_test_12 --password redhat
Error: you must register or specify --org.
[root@jsefler-r63-server ~]# subscription-manager service-level --list --username stage_test_12 --password redhat --org 6532865
+-------------------------------------------+
               Available Service Levels
+-------------------------------------------+
PREMIUM
[root@jsefler-r63-server ~]# subscription-manager register --username stage_test_12 --password redhat --servicelevel=PREMIUM --autosubscribe
The system has been registered with id: 6aa313e5-ef86-4570-b8d4-b1aa2ec437e6 
Service level set to: PREMIUM
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux High Availability (for RHEL Server)
Status:               	Not Subscribed           

Product Name:         	Red Hat Enterprise Linux High Performance Networking (for RHEL Server)
Status:               	Not Subscribed           

Product Name:         	Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
Status:               	Not Subscribed           

Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed               

Product Name:         	Red Hat Enterprise Linux Scalable File System (for RHEL Server)
Status:               	Not Subscribed           

Product Name:         	Red Hat Enterprise Linux Load Balancer (for RHEL Server)
Status:               	Not Subscribed           

[root@jsefler-r63-server ~]# subscription-manager list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+

Product Name:         	Red Hat Enterprise Linux Server
Contract Number:      	2828199                  
Account Number:       	1540170                  
Serial Number:        	413156266640359752       
Active:               	True                     
Quantity Used:        	1                        
Service Level:        	PREMIUM                  
Service Type :        	L1-L3                    
Begins:               	01/20/2012               
Expires:              	01/20/2013               

[root@jsefler-r63-server ~]# 

^^^ VERIFIED: We can now list and successfully autosubscribe with a servicelevel and be granted an entitlement with the desired servicelevel as demonstrated above from the stage environment (where candlepin-0.5.26-1.el6 is now deployed).

Moving to VERIFIED.
Comment 8 errata-xmlrpc 2012-06-20 09:08:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.